Results 1 to 3 of 3
  1. #1
    Bruins's Avatar
    Join Date
    Mar 2007
    Holland, MI

    VTS Trim System issues

    We have a 97 GSX and the trim system is not working. When pushing the button up or down we hear what sounds like a relay clicking but the trim motor is not moving. Does that mean the motor is bad? Is there any test that can be done to check the motor? thanks

  2. #2
    Spike's Avatar
    Join Date
    Oct 2006
    Have you checked for an obstruction at the nozzle?
    The bushings may also be tight if the ring is corroded.
    If that is the case, try disconnecting the rod that moves the trim ring and see if the actuator will work then.

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    League City, Texas

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Variable Trim System (VTS) Study
    By 2Fast in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 06-23-2010, 04:32 AM
  2. vts auto trim system
    By bigmike in forum 2-Stroke Performance
    Replies: 0
    Last Post: 05-26-2008, 12:56 PM
  3. 05 GTX 4tec SC Cooling System Issue
    By jetworx hawaii in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-28-2006, 01:18 PM
  4. Trim system???
    By cr1421 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-20-2006, 12:42 AM
  5. RXP Wedge with "Adjustable VTS Trim Rod"
    By Ultra/RXP in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-22-2006, 05:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts