Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,571
    +1
    112

    RXP Bilge Pump install

    The more I look at the bailer tubes and setup on our RXPs, the less I like it. I also got some water in the hull, and based on what was wet and the water spots all thru the inside of the tubes, I am 99% certain the water came in thru my bailer tubes. Curious if that happens especially when revving up in reverse maybe too ....

    Anyway, I wondered if anybody had already installed a bilge pump in their RXP and completely eliminated the whole bailer setup. I want to do it, don't like the stock setup at all, looks VERY prone to leaks and failures.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,997
    +1
    1,903
    The stock system is very prone to leaks, but not if you take the tie wraps off and replace them with hose clamps. The bailer tubes are very effective in evacuating the water out of your bilge.

  3. #3
    RXPDAVID's Avatar
    Join Date
    Apr 2005
    Location
    West Tennessee
    Posts
    403
    I think I am going to add a bilge pump to mine. There are times when water gets in that you can't run the engine so I will be adding one and will place the output tube so I can see when it comes on.

    David

  4. #4
    I already have a bilige pump on mine, with the green light too when power is on looks cool I have pics but don't know how to put on here.

  5. #5
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,571
    +1
    112
    Frank, I would love to see pics and know where / how the bilge pump was wired in. Sounds like you have neat bilge pump setup!

  6. #6
    Quote Originally Posted by Vern
    Frank, I would love to see pics and know where / how the bilge pump was wired in. Sounds like you have neat bilge pump setup!
    Vern, send me your e-mail and I'll send you the pics.

  7. #7
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,571
    +1
    112
    Frank, my email is VLGARVELI@AOL.COM

    Thanks!

  8. #8
    Quote Originally Posted by Vern
    Frank, my email is VLGARVELI@AOL.COM

    Thanks!
    Pics sent vern. It's wierd all pics were taken with a camera phone last couple of pics were really big

  9. #9
    Frank, thanks for the pics So what brand and size of pump did you install And is it automatic or manual only Also, when you ordered the part from riva, what did they call it (so I know what to ask for) Is it this one http://www.rivayamaha.com/RivaStore/...se%20Fittings# BTW your install looks nice and clean.

  10. #10
    RXPDAVID's Avatar
    Join Date
    Apr 2005
    Location
    West Tennessee
    Posts
    403
    Frank, Send me a picture of your bilge pump setup.

    Thanks,

    David

    davidb@agencyservices.com

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How-To: Bilge Pump Installation in an RXP-X (Lots of Photos)
    By RobWCanada in forum Sea Doo How To & FAQs
    Replies: 46
    Last Post: 08-11-2013, 07:37 AM
  2. RXP bilge pump install question
    By sea-one in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 11-18-2009, 08:33 PM
  3. RXP bilge pump install question
    By sea-one in forum Open Discussion
    Replies: 0
    Last Post: 11-18-2009, 07:14 PM
  4. RXP bilge pump install... Transom outlet ???'s
    By jtskier11 in forum 4-Tec Performance
    Replies: 25
    Last Post: 07-10-2009, 12:33 PM
  5. RXP bilge pump install
    By The Bandit in forum Sea Doo Open Discussion
    Replies: 73
    Last Post: 08-07-2007, 06:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •