Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39

    I took off the pump for the first time.....

    I pulled the pump last night.
    As expected the buttery wear ring was worn.
    I was running a solid 69.8 and touched 70 with it on last time I was out.
    I wonder what it will go like with a new one?
    Also, the pump seal was not installed propely.
    I can't wait to fix it and get out.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	newpics22_001_132.jpg 
Views:	63 
Size:	599.6 KB 
ID:	2117   Click image for larger version. 

Name:	newpics22_006_889.jpg 
Views:	51 
Size:	505.4 KB 
ID:	2118   Click image for larger version. 

Name:	newpics22_007_184.jpg 
Views:	51 
Size:	507.5 KB 
ID:	2119   Click image for larger version. 

Name:	newpics22_008_516.jpg 
Views:	44 
Size:	532.3 KB 
ID:	2120  


  2. #2
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39
    BTW,
    Is there not supposed to be a spacer at the end of the driveshaft?

  3. #3
    RustySeaRustyDoo's Avatar
    Join Date
    Oct 2005
    Location
    Chesapeake Bay-Pasadena, MD
    Posts
    1,788
    Man, that wear ring is toast!

    I cant wait to hear what numbers you get with a new one... Are you sticking with plastic?

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    3
    spacer? you mean a boot on the impeller? where's yours... is it still on the driveshaft? or did u remove it from the prop?

  5. #5
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39
    The boot is still on the shaft. It is snug and I will need to heat it up to get it off. My garage is about 10 degrees F right now.
    Some of the older sea doo pumps I have taken off have a rubber spacer between the end of the driveshaft and the impeller.

  6. #6
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39
    I have to stick with plastic. Expensive mods are out these days due to the little one.

  7. #7
    Site Admin MikeTrin's Avatar
    Join Date
    Apr 2005
    Location
    Overland Park, ks
    Posts
    4,197
    +1
    50
    How long is the riding season where you live in Canada?

  8. #8
    Fast-XPL's Avatar
    Join Date
    Jun 2005
    Location
    Colorado
    Posts
    793
    +1
    20
    I didn't find or see the rubber plug at the end of the shaft you're talking about.

    I was concerned though. I forgot to put one on my XPL and had the shaft come apart running WOT. I looked at the fische and didn't see one for the RXP.

  9. #9
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39
    My season goes from March to November usually.
    I was worried about the plug too. My buddies GSX shaft came out and made a real mess.

  10. #10

    Join Date
    Jul 2005
    Location
    Troy, NY
    Posts
    140
    ok I have never removed my pump, on any of my skis i know there is the 4 bolts and disconnecting all the VTS and steering, what else do i need to do? is it easy? Also is there a special tool i need to remove the impeller?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Took the ski out for the first time today..some questions
    By K-Dubb in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 03-21-2011, 11:31 AM
  2. took out for the first time. But i need help.
    By 750slt in forum Polaris Open Discussion
    Replies: 15
    Last Post: 06-22-2009, 04:04 PM
  3. Took my 06 RXT out for the first time...
    By ajrunke in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-26-2008, 06:05 PM
  4. Took the new RXP out for the first time
    By oneal in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-01-2005, 02:30 PM
  5. took the new rxp out for the first time today
    By mxl16 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-17-2005, 08:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •