Results 1 to 9 of 9
  1. #1
    immred's Avatar
    Join Date
    Jul 2007
    Location
    Manassas VA
    Posts
    154
    +1
    1

    Won't go past 2750 RPM

    Unaltered 2005 RXP. Ran Fine last season.
    First outing ran very rough at first. Had to pump throttle to keep it going. After a few minutes ran fine.
    Changed gas - 2nd outing did sane thing.
    3 rd outing; idled better but won’t go past 27500 RPM. No error codes.
    Any Ideas?
    Any help would be appreciated.


  2. #2
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    what do the plugs look like? How is the battery?

    I'm betting plugs

  3. #3
    I`d say it`s the plugs also
    was the gas treated with restore for the winter?
    water in the fuel?
    those R`s almost sound to close to be in lower limp home mode...PR...

  4. #4

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    Going by the title, I thought this was going to be another sarcastic blown washer thread. Mine won't go past 27500 either... but I'm hoping with the Green SC impeller...

  5. #5
    RiverRat19405, im a rat in the water RiverRat19405's Avatar
    Join Date
    Apr 2007
    Location
    bridgeport pa
    Posts
    261

    96 seadoo gtx bogs down

    yesterday it ran fantastic all day then i found a pin hole in out pipe so got it welded but when i found hole it started to bog down at low rms once im psasst 4 1/2 rpm it flys no promlems onl as idle from 2 to 4 rpm splugs where changed i got low on fuel an used about 3 gals of premix gas would that cause it to bog down?? im at a loss new to ski an dont have a manule yet can any one help me ty river rat

  6. #6
    immred's Avatar
    Join Date
    Jul 2007
    Location
    Manassas VA
    Posts
    154
    +1
    1

    Thanks for the help

    The ski was stored in a shed all winter. The fuel was stabilized. The battery was in the house on a trickel charger. I only have about 20 hours on the engine.
    I'll put in new plugs and take it out Wednesday.
    Thanks for the help. I'll post the results.

  7. #7
    immred's Avatar
    Join Date
    Jul 2007
    Location
    Manassas VA
    Posts
    154
    +1
    1

    too many zeros

    Sorry, I ment 2750 RPM

  8. #8
    immred's Avatar
    Join Date
    Jul 2007
    Location
    Manassas VA
    Posts
    154
    +1
    1

    Smile It was plugs

    I didn't suspect the pulgs. When I did the 10 hour oil change I had changed the plugs just for then hell of it. I only have 20 hours on it now. I was only running on one cylinder. One plug was open and one had a short.

    It it normal to loose two plugs after only 10 Hours.
    Thanks again for the help. I wans't looking forward to Coleman Power Sports at $100 per hour.

  9. #9
    Quote Originally Posted by immred View Post
    I didn't suspect the pulgs. When I did the 10 hour oil change I had changed the plugs just for then hell of it. I only have 20 hours on it now. I was only running on one cylinder. One plug was open and one had a short.

    It it normal to loose two plugs after only 10 Hours.
    Thanks again for the help. I wans't looking forward to Coleman Power Sports at $100 per hour.
    the crap gas (stale) could do it. with plugs ya never know!? sometimes ther sh!t right out of the box...PR...
    glad you got it runnin again!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 Wake Pro 215 won't go past 7000 rpm
    By Jelake in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-24-2016, 11:23 AM
  2. 2007 rxp 215 won't go past 7700 rpms and won't go past 60.
    By Eostrow1 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-02-2016, 10:40 AM
  3. No power won't go past 6000 rpms help!!
    By tocullo in forum 4-Tec Performance
    Replies: 34
    Last Post: 03-10-2011, 03:48 PM
  4. 98 stx won't go past 8mph...rpms do increase
    By mymaries1806 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 07-04-2009, 08:07 AM
  5. won't go past 20mph/4200 RPM
    By jeff0810 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-16-2008, 08:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •