Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 49
  1. #1

    Bearing Housing Came out with Driveshaft?

    Do I need a bearing now? This piece which i am assuming is the bearing cover or maybe piece of it has come off. Is this as simple as putting that metal piece back in or do I need to remove the Rubber flap and oetiker clamps and put a new bearing in there?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSCN6354.JPG 
Views:	109 
Size:	1.21 MB 
ID:	29813   Click image for larger version. 

Name:	DSCN6356.JPG 
Views:	120 
Size:	1.18 MB 
ID:	29814  


  2. #2
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    It looks like you pulled the pto bearing apart. Yes, I would get a new one.

  3. #3
    how much we talking. That it took quite a few hits to loosen that up so that it would come off of the drive shaft. That took a few grunts. Just means more money.

  4. #4
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    They sell the boot with the bearing and clamp as one assembly.

    http://epc.brp.com/default.aspx?bran...,seadoo&lang=E

  5. #5
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    Couldn't tell ya how much- but I'll guess... $100? You need to buy the 2nd oetiker clamp that goes on the pto housing as well- or use a worm drive type clamp...

  6. #6

    Join Date
    Jun 2005
    Location
    rome ga
    Posts
    938
    +1
    20
    If the bearing still works don't waste the money. Put it back in and put a clamp on it. Check the rubber boot for tears or cracks if it's bad it will leak oil.

  7. #7
    it is a clean pull I looked at it inside with my head upside down. My one question, was this a sealed bearing? IF so it would have never come apart right?

  8. #8

    Join Date
    May 2005
    Location
    Fredericksburg, VA
    Posts
    266
    I don't think it has come apart. That bearing is clamped into the rubber boot. Best I can tell it was only put there to support that boot.

    Edit:

    After going outside and looking at mine, I realize that you have pulled the bearing apart. You have the inner portion in your hand and I assume the outer is still in the rubber boot. I don't believe it can be put back together but I could be wrong about that. When I removed my shaft, I removed the clamp at the back of the boot and let the bearing come out of the boot with the shaft.
    Last edited by bankyf; 07-01-2007 at 11:12 PM.

  9. #9
    which boot are you talking about the one that looks like the cv joint on the car where the carbon ring is or the half boot with the two oetiker clamps? i am not sure i follow you.

    Just checked on riva site, the part is an assembly 134.00 for one second of oversite.....arghh!!
    Last edited by yellow4; 07-01-2007 at 11:19 PM.

  10. #10
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    A little advice from someone who knows nothing: Don't be penny wise in this instance... in some cases it can mean an oil leak where everything must come apart again (mess in hull; cursing)... worse yet, a sinking ski- one that goes down very quickly.

    When you have trouble during this disassembly, such as you had- and pull and hit with hammer, etc, etc... safe bet is to replace. Just mho.

    Depending on hours and condition- now is a good time to consider carbon seal replacement also- I certainly would go for a new retaining clip.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Driveshaft/bearing housing broken 2001 GP1200R
    By turnncough in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 09-05-2015, 11:55 AM
  2. Oil filter Union Bolt came out with the filter
    By slingshot in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 08-06-2014, 11:13 AM
  3. When I started my 1050 SLTX oil came out with water.
    By Polaridoo in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-29-2013, 10:05 PM
  4. Getting water out of pump bearing housing?
    By 64physhy in forum Yamaha How To & FAQs
    Replies: 6
    Last Post: 05-02-2013, 01:00 AM
  5. A lot of grease came out of centre bearing
    By fussy1 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 10-04-2010, 01:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •