Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 39
  1. #1
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005

    95 750 motor in a 92 SL650

    Hey guys it runs had a nice ride today. Cold as hell but fun anyway. So here is the ski and some more questions. I had a 92 SL 650 and bought a 95 750 motor and put it in. I am using the 92 cdi box 92 dry pipe and 92 jet drive complete but the whole motor carbs to exhaust is 95 750.

    1. How fast should this thing be I got about 38-40MPH on GPS
    2. I cleaned the carbs and the rubber diaphrams where real dirty and kind of stiff. I used the ones out of the 650 carbs. Will that hurt anything are they the same.
    3. It doesnt plane off very quickly should I look into a different impeller
    4. Should I replace the whole jet drive with something newer with power trim Will that also make it faster
    5. What about changing out the CDI box am I lacking some power because of that
    6. After riding for a couple hours my plugs look kind of black I havent looked at the wash but I thought the dry pipe on the 750 would lean it out any ideas
    7. OK biggest problem I seem to have a leak I think it is coming out of the bearing looking thing on the shaft there is a tube coming up out of it. It seems to only leak when I am really getting on it. Idling around it seems OK. I went today and it wouldnt plane out I looked and it was half full of water. Is there a seal or something that I should replace or check.
    8. How do you check the RPMS without the MFD I want to try and tell if I am running enough or if the impeller is to small etc but its tough.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Quote Originally Posted by race24x View Post
    Hey guys it runs had a nice ride today. Cold as hell but fun anyway. So here is the ski and some more questions. I had a 92 SL 650 and bought a 95 750 motor and put it in. I am using the 92 cdi box 92 dry pipe and 92 jet drive complete but the whole motor carbs to exhaust is 95 750.

    1. How fast should this thing be I got about 38-40MPH on GPS
    A little slow BUT it's probably an impeller issue at this point.
    2. I cleaned the carbs and the rubber diaphrams where real dirty and kind of stiff. I used the ones out of the 650 carbs. Will that hurt anything are they the same.
    The same , did you perform any plug chops?
    3. It doesnt plane off very quickly should I look into a different impeller
    If you have trim, where was it set when you tried to take off?
    4. Should I replace the whole jet drive with something newer with power trim Will that also make it faster
    The newer pump is FAR better. More acceleration, better top end, better steering.
    5. What about changing out the CDI box am I lacking some power because of that.
    I'd change the CDI as it's simple.
    6. After riding for a couple hours my plugs look kind of black I havent looked at the wash but I thought the dry pipe on the 750 would lean it out any ideas.
    The dry pipe actually offers a tad better performance but you may need to make some other mods to get the combo correct.
    7. OK biggest problem I seem to have a leak I think it is coming out of the bearing looking thing on the shaft there is a tube coming up out of it. It seems to only leak when I am really getting on it. Idling around it seems OK. I went today and it wouldnt plane out I looked and it was half full of water. Is there a seal or something that I should replace or check.
    Maybe run it on the trailer at the dock so it can draw water and verify you don't have a leak in the exhaust system anywhere.
    Maybe add water to the hull and confirm your through hull of bearing assembly is leaking.
    8. How do you check the RPMS without the MFD I want to try and tell if I am running enough or if the impeller is to small etc but its tough.
    Purchase an aftermarket tach, the best way to tune is to verify RPM. You'll be able to use it later when tuning for mods.
    I love this one Randy at Watcon sells.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by race24x View Post
    Hey guys it runs had a nice ride today. Cold as hell but fun anyway. So here is the ski and some more questions. I had a 92 SL 650 and bought a 95 750 motor and put it in. I am using the 92 cdi box 92 dry pipe and 92 jet drive complete but the whole motor carbs to exhaust is 95 750.

    1. How fast should this thing be I got about 38-40MPH on GPS
    2. I cleaned the carbs and the rubber diaphrams where real dirty and kind of stiff. I used the ones out of the 650 carbs. Will that hurt anything are they the same.
    3. It doesnt plane off very quickly should I look into a different impeller
    4. Should I replace the whole jet drive with something newer with power trim Will that also make it faster
    5. What about changing out the CDI box am I lacking some power because of that
    6. After riding for a couple hours my plugs look kind of black I havent looked at the wash but I thought the dry pipe on the 750 would lean it out any ideas
    7. OK biggest problem I seem to have a leak I think it is coming out of the bearing looking thing on the shaft there is a tube coming up out of it. It seems to only leak when I am really getting on it. Idling around it seems OK. I went today and it wouldnt plane out I looked and it was half full of water. Is there a seal or something that I should replace or check.
    8. How do you check the RPMS without the MFD I want to try and tell if I am running enough or if the impeller is to small etc but its tough.
    1. A 650 should run around 40-45 MPH on flat water. 2. Carbs are identical from 650 and 750 except the jet sizes. 3. Lose the old style jet pump and replace with a newer style. (94 and up) 4. Newer pump yes, trim would be nice to have. Best performance would be gained woth a long pump. 5. CDI box should be swapped with a 750. The timing is more advanced for a 750 than the 650. It won't hurt (650), but 750 will be better. 6. Check the wash for sure, it will tell you everything you need to know. 7. The driveshaft bearing/seal it the part I believe you are asking about. It should be greased regularly along with the engine coupler. If it is bad, you can find one on Ebay for around $30 used, or $60 new. Half full of water means you have a MAJOR leak. Try filling the inside with some water and look for water leaking out. Tipping the boat up helps from having to put alot of water into it to find the leak. 8. You need a tachometer. Tiny Tach is listed in the Ebay BIN for $45 shipped.

  4. #4
    Bing-A-Ding-Ding-Ding, Brrrrrap! Brrrrrrrrrap!!! Polaris_Nut#1's Avatar
    Join Date
    Aug 2006
    Location
    Pittsfield, MA
    Posts
    3,350
    +1
    26
    The safest / easiest way to go would be to add a 94 or 95 750 jet pump and impeller and add the wet pipe and be done with it. But of coarse if you are a horsepower junky / speed freak. You need to search the posts about people adding the dry pipe to 750' and 780's. You def need a newer pump, a 97 PRO CDI, an 11/17 impeller and big big jets. And nobody can tell ya what size jets yet, cause most of them try the entire Pro intake system, reeds, manifold and carbs.

  5. #5
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    What year and model pump should I be looking for? I found an end on Ebay that has the power trim cup on it but it is just the end or nozzle, would this improve my existing pump or buy it just to have the trim and add it to a newer pump http://cgi.ebay.com/ebaymotors/ws/eB...6335443&rd=1,1
    Here is the trim motor on Ebay as well.
    http://cgi.ebay.com/ebaymotors/ws/eB...9982407&rd=1,1

    Here is a newer style pump too I think it is the correct year Maybe I should buy all three and have everything

    http://cgi.ebay.com/ebaymotors/ws/eB...2389856&rd=1,1

  6. #6
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    You're looking for the longer pump assembly like that of a 96 and newer, it will have another 4 inch extension added to the photo you have.

  7. #7
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    So the newer short pump is not better? I will try and see if I can find a long one but what else will I need to make it work driveshaft etc. I thought a short one but newer and trim would be a noticeable gain.

  8. #8
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    OK some new problems cropped up today.

    1. Not enough power to plane out with 2 people. I know I am a big guy but I thought it would still carry my stepdaughter and I. I am 265 she is about 130 it felt like it was cavitating. I checked the impeller and it is not damaged but some very small knicks what else can I like for?

    2. OK I pulled the bearing out that seals the shaft off it sounded like it was making a noise. I thought it was supposed to have a grease fitting instead it has a line and a nozzle fitting Is there a bearing or something in there that is supposed to turn it looks like a bronze guide rather than a bearing. See picture below. Do I need to upgrade to a greasable one or am I missing something.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	SA400104.JPG 
Views:	74 
Size:	558.1 KB 
ID:	29897   Click image for larger version. 

Name:	SA400090.JPG 
Views:	68 
Size:	838.3 KB 
ID:	29898   Click image for larger version. 

Name:	SA400089.JPG 
Views:	59 
Size:	658.2 KB 
ID:	29899   Click image for larger version. 

Name:	SA400088.JPG 
Views:	65 
Size:	562.4 KB 
ID:	29900   Click image for larger version. 

Name:	SA400092.JPG 
Views:	62 
Size:	568.5 KB 
ID:	29901   Click image for larger version. 

Name:	SA400091.JPG 
Views:	65 
Size:	488.6 KB 
ID:	29902  


  9. #9
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Quote Originally Posted by race24x View Post
    OK some new problems cropped up today.

    1. Not enough power to plane out with 2 people. I know I am a big guy but I thought it would still carry my stepdaughter and I. I am 265 she is about 130 it felt like it was cavitating. I checked the impeller and it is not damaged but some very small knicks what else can I like for?

    Any idea what size impeller you have in there? Maybe it's incorrect for your application and you're just spinning it out.
    You can check for a leak into the pump arena, when they draw air instead of water you can have the same issue. I've had many in which I had to re-seal the pump shoe.

    2. OK I pulled the bearing out that seals the shaft off it sounded like it was making a noise. I thought it was supposed to have a grease fitting instead it has a line and a nozzle fitting Is there a bearing or something in there that is supposed to turn it looks like a bronze guide rather than a bearing. See picture below. Do I need to upgrade to a greasable one or am I missing something.
    It looks like somebody converted it to an oil bath system of some sort. I'd remove the hose system they have and install a zirk fitting and then lube her up, after replacing the seals of course. It might be easier to just replace the entire thing as well??

  10. #10
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    I am glad someone knew what it was I am looking to get a whole new one. I couldnt figure out from Polaris what the heck the parts where I also talked to a guy is the shoe the thing on the bottom like a grate? The seals are shot in that bearing thing too could that leak air in? How do I seal up some of that stuff?

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 95 750 motor parts
    By JMF1 in forum Polaris Classifieds
    Replies: 3
    Last Post: 08-06-2011, 06:00 PM
  2. '95 750 engine in a '93 750
    By cubsfan2516 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 04-30-2009, 03:55 AM
  3. 95 sl750 CDI in a 92 sl650??
    By cubsfan2516 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-03-2008, 05:58 PM
  4. Can you put a 750 motor in a 650 hull??
    By cubsfan2516 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-02-2008, 07:32 PM
  5. Difference in 95 SL750 vs 92 SL650 Intake Grate?
    By delagem in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-01-2007, 09:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •