Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    NottaPhireMan's Avatar
    Join Date
    Aug 2005
    Location
    SoCal, Glamis or The River
    Posts
    72
    +1
    1

    Thought I lost my S/C

    Put my '05 RXP in the water last week on the first day of our week long vacation. Started like a champ, idled wonderfully out of the no wake zone, but just before I got to the buoys the motor suddenly sounded different. I slowly opened the throttle & could tell things were not right. I could only get a top speed between 38-40 mph. The rpms were jumping all over, when idling it went from 1550-2100, not normal for my ski which idles at 1750-1850. I pulled it out of the water & called the closest 'doo dealer. He was really cool so I thought I'd leave it with them to repair as needed.

    Well he called me today & said that my #2 plug was fouled really bad they replaced & the motor runs fine. He said my thrust is down about 100psi & blamed that on a wear ring & nose cone. My ski has only about 28 hrs on it, isn't that pretty soon for a wear ring to fail?

    Anyway, time to do my homework I guess & check into these parts. I have not given them the go-ahead to reapair yet as I want a little more info first.


  2. #2
    Quote Originally Posted by NottaPhireMan View Post
    My ski has only about 28 hrs on it, isn't that pretty soon for a wear ring to fail?
    No. It depends on how shallow of water you ride in and if you take a lot of sand through the pump or not. Generally they need to be replaced every 50hours if you're careful, but I've seen people chew them up good in less than 10 hours.

  3. #3
    I got 41 hours out of mine. Last time out I noticed at 200 rpm drop so I flipped it last night. Hope that solves my problem

  4. #4
    North Carolina Hoovermaneuver's Avatar
    Join Date
    Apr 2005
    Location
    Benson, NC.
    Posts
    816
    +1
    26
    I made it 10 minutes once...lol

  5. #5
    I got tired of this and mounted the ss last weekend

  6. #6
    NottaPhireMan's Avatar
    Join Date
    Aug 2005
    Location
    SoCal, Glamis or The River
    Posts
    72
    +1
    1
    Quote Originally Posted by RXPkid View Post
    No. It depends on how shallow of water you ride in and if you take a lot of sand through the pump or not. Generally they need to be replaced every 50hours if you're careful, but I've seen people chew them up good in less than 10 hours.
    I had a '95 s.d. HX with alot of hrs. on it (200+) when I sold it & never had a wear ring problem. I figure it had one also. I ride my new rxp in the same places.

    Can I upgrade from to a better than stock wear ring?
    How hard would it be to change out. By that I really mean does it require any special tools? I am not afraid to do the work myself.

  7. #7

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by Dark_viper42 View Post
    I got 41 hours out of mine. Last time out I noticed at 200 rpm drop so I flipped it last night. Hope that solves my problem
    i get 14hours then a new one

  8. #8
    NottaPhireMan's Avatar
    Join Date
    Aug 2005
    Location
    SoCal, Glamis or The River
    Posts
    72
    +1
    1
    So what would 'cause my plugs to foul? The boat only has 28 hrs on it. It's not a two-stroke.

  9. #9
    Quote Originally Posted by NottaPhireMan View Post
    Can I upgrade from to a better than stock wear ring?
    How hard would it be to change out. By that I really mean does it require any special tools? I am not afraid to do the work myself.
    Yes you can. It's the SS (stainless steel) wear ring. Only thing special you'll need is the impeller removal tool and a breaker bar. Other than that a descent tool kit is necessary with metric sockets. It's easy.

    Quote Originally Posted by NottaPhireMan View Post
    So what would 'cause my plugs to foul? The boat only has 28 hrs on it. It's not a two-stroke.
    Bad gas...too much gas (doubtful)...going through winterizing periods (fogging oil)...bunch of stuff.

  10. #10
    NottaPhireMan's Avatar
    Join Date
    Aug 2005
    Location
    SoCal, Glamis or The River
    Posts
    72
    +1
    1
    When you say going through winterizing periods (fogging oil) what do you mean exactly? This was my first time out for the year.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 16
    Last Post: 09-22-2006, 07:02 PM
  2. Lost my ignition key, can I use any key?
    By Hecyan in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-09-2006, 08:00 AM
  3. LOST my RXP manual on the computer can someone help?
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 01-21-2006, 10:44 PM
  4. Thought I lost the Clutch Sunday???
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-16-2005, 01:05 PM
  5. lost my clutch today
    By Green Hulk in forum 4-Tec Performance
    Replies: 30
    Last Post: 06-14-2005, 07:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •