Results 1 to 10 of 10
  1. #1
    XLTNoob
    Join Date
    Jul 2007
    Location
    Baytown, TX
    Posts
    400

    basic pump questions - '01 1200XLT

    I've got a 2001 1200XLT

    I'm ordering another "Premium" engine from sbt, and while I'm at it...


    The pump used to cavitate just a little bit on holeshot (when it was running).
    Is my pump the same as the one on the GP1200?
    Is there a simple wear ring I can replace, like on the seadoos?
    Is it worth replacing the intake grate?

    I'm fairly certain what caused the problem, a couple of years ago, I attemped to pull out a beached boat while in about a foot of water. No issues other than the slight cavitatioin on holeshot.
    Last edited by Jolly Roger; 07-02-2007 at 01:23 PM.


  2. #2
    Dirty Sanchez's Avatar
    Join Date
    Dec 2005
    Location
    Northern Virginia
    Posts
    1,038
    Stop the order if it hasn't been done. What is wrong with your engine?? Just to let you know the sbt motor is ok if your just doing rec riding, but if your going to look for big speed out of that xlt you are going to need an oe with stock cylinder not sleeved sbt cylinder. The ports don't line up proper. You lose 250-350 rpms.
    mod list Jims1300 ride plate
    intake grate
    pump seal
    prop
    To answer you question no wear ring like the Doo's. Metal liner pressed into place you can have is re-lined or replaced
    Also 05 HO style pump is good for some additioonal speed
    Were are you loacated??

  3. #3
    Dirty Sanchez's Avatar
    Join Date
    Dec 2005
    Location
    Northern Virginia
    Posts
    1,038

    Smile xlt help

    you need to visit jims1300 in the tuners corner. he is the premier xlt guy

  4. #4
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Welcome to the forum !

    Yes, Jim is out XLT man !

  5. #5
    XLTNoob
    Join Date
    Jul 2007
    Location
    Baytown, TX
    Posts
    400
    Quote Originally Posted by Dirty Sanchez View Post
    Stop the order if it hasn't been done. What is wrong with your engine?? Just to let you know the sbt motor is ok if your just doing rec riding, but if your going to look for big speed out of that xlt you are going to need an oe with stock cylinder not sleeved sbt cylinder. The ports don't line up proper. You lose 250-350 rpms.
    mod list Jims1300 ride plate
    intake grate
    pump seal
    prop
    To answer you question no wear ring like the Doo's. Metal liner pressed into place you can have is re-lined or replaced
    Also 05 HO style pump is good for some additioonal speed
    Were are you loacated??

    1. I havent ordered the engine yet.
    2. The engine was filled with water and sat for 2 years. Bottom end is trashed.
    3. I only do rec riding, but I may want a bit of speed out of it in the future.
    (I read on sbt's forums that they overbore 1mm)(cant i just replace top end later if I get serious about racing?)
    4. What are the mods intended for? Just basic "stage 1"? Or serve one of my needs?
    5. I'm in Houston, TX

  6. #6
    Dirty Sanchez's Avatar
    Join Date
    Dec 2005
    Location
    Northern Virginia
    Posts
    1,038

    you got mail

    check you personnal message I sent you a note
    SBT motor work fine, I personnal haven't had problem, but my friend used a sbt top end on his gpr and lost 300 rpms, I looked at the posts from cylinder to the sleeve and they weren't matched. Not even close. Other than the lost of rpms/ overall speed they are fine. You could always get the regular package. Ride it until the warrenty expires and then have the cylinders ported / matched. Also, update the base, head and exhaust gasket to the oe which have a rubber coating on them. This seals better than metal gaskets that are painted black
    Last edited by Dirty Sanchez; 07-02-2007 at 02:42 PM. Reason: add info

  7. #7
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    There are a few of us in the Houston Area.

    there is one performance shop that you can call locally.
    He is a member on the forum here also

    www.wfoperformance.net
    Richard Patterson
    713-725-8596

  8. #8
    Dirty Sanchez's Avatar
    Join Date
    Dec 2005
    Location
    Northern Virginia
    Posts
    1,038

    water in the engine for 2 year?

    How about the carbs? have they been torn down and checked let? You might want to find out whats up with them as well

  9. #9
    XLTNoob
    Join Date
    Jul 2007
    Location
    Baytown, TX
    Posts
    400
    looks like you guys have a lot of experience with these skis.. lots of good advice.

    Gonna get my old seadoo sold and get to the point where I can tear down this motor to see what I've got. I'll decide the path to my destruction then

  10. #10
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    Welcome Fuxxy

    I have an account with SBT, but have only used them for Seadoo stuff. I am pretty sure they use sleeves in there Yami top ends, where Yamaha uses nicasil. The sleeves almost never line up correctly with the ports. Also a while back they had problems with crank bearings. Plus, you know the carbs are going to need to be gone thru completely, if they are even useable.

    PM me your number and I will help anyway I can

    Rich

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bilge Pump Questions
    By Piney in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 03-18-2006, 09:33 AM
  2. more pump questions
    By chip in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 02-25-2006, 08:00 PM
  3. Island racing and 05 pump question ??
    By slow1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 02-17-2006, 12:27 AM
  4. pump question
    By rxpblast in forum 4-Tec Performance
    Replies: 6
    Last Post: 01-11-2006, 09:37 PM
  5. pump question
    By skillet in forum 4-Tec Performance
    Replies: 16
    Last Post: 01-06-2006, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •