Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    05 Sea-Doo RXP Problem!

    Hello guys, I have a 2005 Sea-Doo RXP with 36 hours. Yesterday I took it for a ride and I notice my RXP is barley hiting 60mph. It was going around 50-55 mph and the RPMS were 6000-6500. My friend has the same Sea-Doo RXP 05 but with more hours and his RMPS were going easy around 8000 and hiting 60+mph. We were racing together and it just burned me. So I want to know what is causing my RXP go around 50mph and RPMS around 6000-6500?


  2. #2
    BOOSTED's Avatar
    Join Date
    Oct 2006
    Location
    ARUBA
    Posts
    359
    Well sorry to tell you this but your supercharger took a dump with those ceramic washers.

    Btw welcome to the forum.

  3. #3
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,627
    +1
    806
    http://greenhulk.net/forums/showthre...clutch+failure

    For future reference the link can be found on the sidebar on the left. It's under SC CLUTCH FAILURE and it's in BOLD.

  4. #4
    I also furgot to write that, after riding like that with low RPMS, at the end of the day MAINT came on, on my speedometer. You think it is just telling me that my S/C washers are blown or the bearings messed up?

  5. #5

    Join Date
    Jul 2006
    Location
    Acworth, GA
    Posts
    157
    +1
    1
    Quote Originally Posted by eimutisj View Post
    I also furgot to write that, after riding like that with low RPMS, at the end of the day MAINT came on, on my speedometer. You think it is just telling me that my S/C washers are blown or the bearings messed up?
    1) SC Clutch is probably blown (see the link mentioned above)

    2) You're probably due for a regularly scheduled oil change.

  6. #6
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Quote Originally Posted by eimutisj View Post
    I also furgot to write that, after riding like that with low RPMS, at the end of the day MAINT came on, on my speedometer. You think it is just telling me that my S/C washers are blown or the bearings messed up?
    You rode it the rest of the day with it having a problem, lmao Did you think it was going to fix it self some how?Id say steel washers and a new engine and youll be fine.

  7. #7
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    I love these posts. Hey the warranty will take care of it.

  8. #8
    Quote Originally Posted by Ultra250 Tn View Post
    You rode it the rest of the day with it having a problem, lmao Did you think it was going to fix it self some how?Id say steel washers and a new engine and youll be fine.
    I only noticed towards the end of the day. New engine for what ?

    Also NCHeel how will they warrantie it if its 05 and its been two years now? I dont have extended warrantie on it.

    Also does anyone know where i can find a poste or a site on how to take apart the S/C? and what tools to use?
    Last edited by eimutisj; 07-02-2007 at 08:49 PM.

  9. #9
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,627
    +1
    806
    New engine because the ceramic washers blew up and got sucked into your motor while you rode your ski at 6000 rpms. It'll be an expensive fix and you'll have to take apart more than just your supercharger.

  10. #10
    Quote Originally Posted by JFizzleJR View Post
    New engine because the ceramic washers blew up and got sucked into your motor while you rode your ski at 6000 rpms. It'll be an expensive fix and you'll have to take apart more than just your supercharger.
    Change the oil pumps?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 Sea Doo RXP Burnt Wire in wiring harness
    By RobBryan in forum 4-Tec Performance
    Replies: 1
    Last Post: 03-28-2016, 06:27 PM
  2. Replies: 5
    Last Post: 04-22-2014, 07:46 PM
  3. 05 sea doo 3d problem
    By lotown3di in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-12-2013, 10:11 AM
  4. HELP PLEASE H-TEMP PROBLEM 05 Sea Doo RXT
    By scott93310 in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-31-2011, 01:48 PM
  5. Sea Doo RXP 2005 Starting Problems
    By rolo2230 in forum Sea Doo Open Discussion
    Replies: 21
    Last Post: 05-17-2010, 10:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •