Results 1 to 8 of 8

Thread: thanks jerry

  1. #1

    thanks jerry

    just got off the water from doing speed runs on an 04 rxp with riva stage 1 kit and some extra goodies I bought from jerry's on line store, was doing 65 mph ( bad wear ring and slightly damaged prop) to 74.3 with new wear ring , 14/19 impellar , riva intercooler ,riva thru hull exhaust, new ecu program , riva pro series block offs and man that thing gets it quick! before new ecu last week speed runs were at 70 mph, today full tank 1600 ft elevation 215 lbs rider on choppy and windy conditions improved time by over 4 mph I havent even put on the specially pitched prop (15/20) that jerry just sent me. If you are even slightly considering a new race ecu, DO IT! unreal acceleration and lots of top end. I saw 8550 flash for a second and stayed @8400 thanks for the great parts and all the good advice jerry, I will repost new times with the new 15/20 next tuesday.


  2. #2
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    are u going to buy a vortech impeller to go with that setup......that will help even more.......u might have one already but i didn't see it in ur parts list.....great numbers to man!

  3. #3
    Moderator two2curupt's Avatar
    Join Date
    May 2005
    Location
    Toronto, Canada
    Posts
    2,982
    +1
    41
    Cool ECU has a 8600 rev limit now...BUT BE CAREFULL!!!...Before you go much higher with the rpms...Lighten the valve trane...So you reduce float..

  4. #4
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    9,367
    +1
    623
    Was the 70 before the IC or after?

    Dam your flyin...

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,886
    STEVEN that is unreal speeds for 1600 ft elevation and windy choppy conditions.

    Glad to hear it. The 15/20 WILL get you more speed AND better acceleration

    Just remember, we MUST limit your RPM's to 8400... you don't ever want to see flashes of 8550 with the stock valvetrain.

    Man, the new ECU is unreal!!!

    Good luck in the Mark Hahn 300 race at the end of the month!

  6. #6
    Quote Originally Posted by Water4fire
    Was the 70 before the IC or after?

    Dam your flyin...
    70 mph was with i/c but stock ecu, my maint. light flashes witch is normal but when I crank up the r's the display reads check engine. eng temp is around 66 and just had fresh oil change, not sure about that check eng warning. monday I will try out the 15/20

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,961
    +1
    1,886
    Steven, its normal for "MAINT" to flash for 5 seconds at startup with the racing ECU.

    You need to press "set" 5 times and see what kind of trouble code it's throwing for the "check engine" alarm.

    Make sure your oil is not over filled.

  8. #8
    skillet: those are awsome results dude! You just can`t go wrong with advice from this site! Jerry`s the bomb! ...PR...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Thanks Jerry
    By Insanediego Joe in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 05-04-2006, 07:41 PM
  2. WOW WOW WOW !!!! Thanks Jerry :)
    By rxp_boy in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-01-2006, 12:19 PM
  3. Thanks Jerry
    By HOSS in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-14-2006, 10:24 PM
  4. Thanks Jerry! --Jerry's repitch on my 15/20 solas....
    By VFX_Artist in forum 4-Tec Performance
    Replies: 8
    Last Post: 11-01-2005, 11:07 AM
  5. Thanks Jerry
    By Bullit in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-28-2005, 12:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •