Results 1 to 3 of 3
  1. #1

    Stalling on acceleration

    I am new to the Green Hulk...I purchased a 95 Polaris SL 750 last year. I am having some troubles with it and I am hoping for some assistance. It idles good, it runs good at all speeds except when quickly accelerating from a dead stop (engine idling). The engine will instantly stall.

    I can quickly accelerate to full throttle from any other speed but idle. Any help would be greatly appreciated.

    Thanks in advance

  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Check the tech section. Look under Tuning Tips All Engines/Carbs

    Here is a start.
    Tuning Tips for Girls

    Start with the screws set at 1 turn out, and tune with the tachometer for peak Rpm, then stop there and count the number of turns on the high speed screws. Write this down on a piece of paper.. Then turn the high speed screws in all the way and open them to 1/4 turn open. (Now you will be testing starts only, so no more big high rpm trips around the course). You are only turning in the high speeds to allow you to easily tune the low speeds.

    Now check the low speed screws and set them at 1 turn and do a practice start; To test the low speed setting pretend that you just jumped the start and you have to start with no holder. Hold the ski by yourself and hold as many Rpm as you can (don't blow it out first for testing) and then nail the throttle hard.... NO FARTHER THAN 50 KILOMETERS, as you are only testing the start response

    If it blubbers like a schoolgirl trying to guzzle a quart of beer, then it's too rich on the low speed screws..
    If it falls flat on the line (like someone punched you in the stomach).. It's too lean on the low speed screws.

    When you like the acceleration off the line, stop there and count the number of turns on the low speed screws. Write this down on a piece of paper.. Then re-set your high speed screw where they show the best peak Rpm earlier and try both a start and a peak Rpm run...
    It will probably "blubber" a little off the line... DO NOT turn in the low speed screws... Instead, go back out on the course and fine tune for peak Rpm again.. The blubbering off the line is caused by having too much fuel in the high speed circuit... Write down your new high speed setting on the piece of paper along with the best low speed setting that you found earlier, this will be your base-line carburetor settings.
    If the high or low speed screws are open more than 11/4 turns, then you need to swap to the next bigger jet.
    If the high or low speed screws are closed all the way, then you need to change to the next size smaller jet.

    *** If no matter what you try, it still won’t leave the line without falling on its face "lean bog"... Then try the next size lower pop-off spring in the carbs... Don't be afraid to try #95 or even #80 gram springs..

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    Hello turbo, WELCOME to the Green Hulk Forums.

    Sounds lean, have you tried to use the choke and see if it gets better?
    These are famous for lean running conditions, be sure to verify you're not running lean.

    I'd be checking for fuel restrictions.

    Fuel Pump (I like the triple outlet)
    New hoses as they kink over and swell.
    Possible fuel valve

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help with 2000 Gp1200R stalling. idles fine, can't accelerate
    By lib135 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 05-20-2013, 01:41 PM
  2. 98 SLTX stalls on acceleration; won't idle
    By Racer26 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 05-27-2012, 09:09 PM
  3. How To: track acceleration using GPS
    By Kinchyle in forum Sea Doo How To & FAQs
    Replies: 17
    Last Post: 07-15-2011, 11:27 AM
  4. Prop bending ... best acceleration ....
    By VFX_Artist in forum 4-Tec Performance
    Replies: 3
    Last Post: 12-09-2005, 08:02 AM
    By rxtmad in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-30-2005, 12:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts