Results 1 to 2 of 2
  1. #1

    1997 polaris SL 1050

    Hello i need some help just purchased a sl 1050 polaris and it is only firing on 2 cylnders and not the third does anyone have any ideals what this could be and does anyone have used parts for this model any info would be greatly appreciated thanks bobby


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Try triming the spark plug wires back 1/4" Remove the plug boot and trim 1/4" and reinstall.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Parting out: Freshwater 1997 Polaris SL 1050
    By nightrider05 in forum Polaris Classifieds
    Replies: 20
    Last Post: 06-19-2014, 12:59 PM
  2. 1997 polaris sl 1050 stator upgrade
    By cfarley04 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 09-29-2010, 09:20 PM
  3. 1997 polaris sl 1050 no fire
    By jeremy williams in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-10-2010, 05:27 PM
  4. FS 1997 Polaris SL 1050
    By espritonsevas in forum Polaris Skis
    Replies: 0
    Last Post: 07-25-2010, 11:08 PM
  5. 1997 Polaris SL 1050 w/ mods & 2-place Shoreland'r Trailer
    By cubsfan2516 in forum Polaris Skis
    Replies: 9
    Last Post: 10-07-2008, 02:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •