Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    camar0's Avatar
    Join Date
    Apr 2007
    Location
    Sunshine
    Posts
    787

    This happen to anyone else? Lol

    was riding ski hard with turns and also pulling alot of weight for tubing and late in the afternoon the ski's steering just stopped working.... sucks when you are in the middle of the lake and you really can only make left turns.... heh.... this is what i saw when i pulled it out of the water....

    P.S. this is no longer a problem since frank fixed it
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0681.JPG 
Views:	114 
Size:	132.8 KB 
ID:	30419   Click image for larger version. 

Name:	IMG_0683.JPG 
Views:	111 
Size:	109.2 KB 
ID:	30420   Click image for larger version. 

Name:	IMG_0682.JPG 
Views:	97 
Size:	79.2 KB 
ID:	30421  


  2. #2
    holy crap, did you break the nozzle? and why is the top right nut busted in 2? Did the reverse bucket drop down while at speed?...PR...

  3. #3
    pet's Avatar
    Join Date
    May 2006
    Location
    Washington DC metro
    Posts
    1,317
    uhh...sory for that, i don't want this to happen with my ski when i'm on the midle of the Potomac riding like i stole a ski

  4. #4
    camar0's Avatar
    Join Date
    Apr 2007
    Location
    Sunshine
    Posts
    787
    PR... yea the steering nozzle is toast... lol....

    yea half the nut on the top right stud was gone as well...

    no idea what happened but it wasnt fun....

  5. #5
    the only time I have ever seen this is if the reverse bucket came down at some speed.

  6. #6
    Mentally Unstable dochere195's Avatar
    Join Date
    Jun 2007
    Location
    Algonquin, IL
    Posts
    174
    Yea, I did that once. Doing power dives on my old ski. Freaked me out as I didn't realize it right away and went to take off only to find out straight was the only way I would be going...

  7. #7
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1
    looks like maybe u were turning and the rope was caught on nozzle w/ slack in it, then when tightned up...snap.....or maybe not....glad its taken care of

  8. #8
    THE OFFICAL SUPERDUTY!!!!!! superduty's Avatar
    Join Date
    May 2006
    Location
    Webster, Texas
    Posts
    4,726
    +1
    5
    i see you have the reduction nozzle u didnt loose the ring in that did you???

  9. #9
    camar0's Avatar
    Join Date
    Apr 2007
    Location
    Sunshine
    Posts
    787
    nah, no ring was used at the time

  10. #10
    question is: it really looks like it took a good whack, so what else might be damaged? I would thoroughly check out the pump...pump support...etc...PR...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. R&D intake Grate on 2012 SHO Cruiser. Has this happened to anyone before?
    By Dragdaddy71 in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 06-13-2013, 09:48 PM
  2. Hope this never happens to anyone else....
    By angelsfann02 in forum Polaris Open Discussion
    Replies: 18
    Last Post: 08-26-2009, 12:11 PM
  3. Has this happened to anyone?
    By bossdukes in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 01-18-2007, 03:34 AM
  4. "WOW" could this happen to you?
    By peteshauling in forum Yamaha PWC Performance (2-stroke)
    Replies: 28
    Last Post: 06-25-2006, 04:19 PM
  5. Don't Let this Happen to you!!
    By Red Devil in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-19-2006, 09:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •