Results 1 to 3 of 3

Thread: Question

  1. #1

    Question

    This is the deal. Im getting a hook up on a 900 motor from a buddy of mines. My question is can I use the carbs, impeller and exhaust from the 1050 on this motor. Please help, this is for next weekend so that I have a ski for the keys, so I kind of need answers quickly. BTW this motor is just until i can do the 1200 swap. Thanks in advance for the help. Tony


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Yes

  3. #3
    Thanks alot

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  2. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  3. Oil Level question , this thing mixes me up :(
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-23-2005, 10:03 AM
  4. Question for the Hulk
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-20-2005, 07:13 AM
  5. RXP VTS Question
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •