Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
  1. #1
    mstennes's Avatar
    Join Date
    Jul 2006
    Location
    On the Columbia River above a Dam
    Posts
    843
    +1
    1

    Riva Intercooler Question aka What A Weekend

    Ok I just cleaned out my Riva Intercooler and when I hooked it back up I forgot to hook up one clamp no biggeee as its still on the trailer and I have it hooked up to a hose checking for leaks and making sure the dang J tube and pissers are getting water, but I noticed it blowing water out the intake line going to the throttle body. Is this normal or is there a rupture in the intercooler allowing the cooling water into the intake? Help I need to know as its hot and I want to ride.
    Thanks,
    Mike
    Last edited by mstennes; 07-07-2007 at 01:45 PM.


  2. #2
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    you shouldn't have any water entering the intake. Are you a salt water rider?

  3. #3
    mstennes's Avatar
    Join Date
    Jul 2006
    Location
    On the Columbia River above a Dam
    Posts
    843
    +1
    1
    Quote Originally Posted by _Lurker_ View Post
    you shouldn't have any water entering the intake. Are you a salt water rider?
    NO its strictly a freshwater machine. All I have done is cleaned it out or I should say flushed it out with water and a all metal radiator cleaner mixed very dilute and then promptly flushed with regular water. It had allot of Milfoil and other crap in it though as I strained what came out and there was no metal or rust so what the????

  4. #4
    Maybe it got frosen under the winter? do you have it outside?

  5. #5
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    there have been a lot of these riva intercoolers leaking. How much water is coming out of the intake/exit of the intercooler? Sounds like you have a leaking core. You run the risk of hydro locking the engine if you run it like this.

  6. #6
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Riva says they gaurantee them, don't they?

  7. #7
    mstennes's Avatar
    Join Date
    Jul 2006
    Location
    On the Columbia River above a Dam
    Posts
    843
    +1
    1
    Quote Originally Posted by Swedie View Post
    Maybe it got frosen under the winter? do you have it outside?
    Nope heated shop and fully winterized. No it worked fine up until the exhaust warning light went on Thursday, I just got it all back together and noticed that.

  8. #8
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    look at your radiator cleaner container and see if it is safe for aluminum. some acids eat up aluminum very quickly. phosphoric acid based cleaner like CLR is what is safe.

  9. #9
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    Quote Originally Posted by Hydrotoys View Post
    Riva says they gaurantee them, don't they?
    If im not mistaken i've heard olny for the first 3 months.

  10. #10
    Quote Originally Posted by Hydrotoys View Post
    Riva says they gaurantee them, don't they?
    Only for the first 30 days.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RIVA Intercooler Question
    By Carlos Thomas in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 05-01-2010, 05:32 AM
  2. Riva Intercooler question
    By JeffTurbo601 in forum 4-Tec Performance
    Replies: 10
    Last Post: 10-16-2007, 12:48 PM
  3. Riva intercooler question
    By mstennes in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-11-2006, 05:55 PM
  4. riva Intercooler question and IC blocking
    By amirmiz in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-01-2006, 10:25 AM
  5. riva intercooler question
    By amirmiz in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-04-2006, 05:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •