Results 1 to 7 of 7

Thread: Losing Rpms

  1. #1
    tony4963's Avatar
    Join Date
    May 2007
    Location
    rhode island
    Posts
    35

    Unhappy Losing Rpms

    hi guys thanks for all the input latley you sure did help me out
    last season was running 8100 rpms late in the season
    this yr cant get over 7400 rpms changed the wear ring checked prop
    think my sc is slipping lots of fuel residue in the tube stick my finger in there an can turn it clockwise still have the factory washers any ideas
    hope you can help one more time


  2. #2

    Join Date
    Jun 2007
    Location
    Aliso Viejo, CA
    Posts
    18
    Quote Originally Posted by tony4963 View Post
    ...still have the factory washers any ideas
    hope you can help one more time
    Your ceramic washers in the SC probably shattered. How long have you driven your ski like this?

    If you have spent any time on this site you will find approx 100 posts with the same symptom/problem. Is your ski still under warranty?
    Last edited by whit33; 07-07-2007 at 07:58 PM.

  3. #3
    ARNYGOLLOTT3's Avatar
    Join Date
    May 2007
    Location
    Biloxi, MS
    Posts
    810
    DO NOT RIDE until you have an answer, check your S/C, remove it, inspect it, it is not difficult, I did mine for the first time just a few days ago, took about 45 minutes, could do it in 20 today, anyhow if your lucky you just need spring washers...either way you cannot ride again until you get the ceramics out (if they are still in there ), I am no mechanic, but the process is really easy, go to "How to and FAQ" section of this forum

  4. #4

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by tony4963 View Post
    hi guys thanks for all the input latley you sure did help me out
    last season was running 8100 rpms late in the season
    this yr cant get over 7400 rpms changed the wear ring checked prop
    think my sc is slipping lots of fuel residue in the tube stick my finger in there an can turn it clockwise still have the factory washers any ideas
    hope you can help one more time
    please get the ceramics out. i'll not tell u again

  5. #5
    El Tartaro luismendez25's Avatar
    Join Date
    Jun 2005
    Location
    Orlando, Fl
    Posts
    555
    Im no expert but if you are turning 7400 rpms your washers are still there but dont ride it again because they might be about to dissapear. Get that charger out and put metals before your Rpm's go down to the 6000's and you have to repair oil pumps.

  6. #6
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    http://www.greenhulk.net/forums/show...e+supercharger



    Takes an easy 15 minutes with hand tools.

  7. #7
    tony4963's Avatar
    Join Date
    May 2007
    Location
    rhode island
    Posts
    35

    Unhappy

    kind of figured that much didnt really didnt want to hear it but thanks im going to pull the sc tomorrow jerry is out of washers so im going to have to go to riva hopfully i can send it to jerry to fix it but ill have to see what he wants to do about the washers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gpr1200 runs good till 3/4 throttle then loses rpms and speed at full throttle
    By zigp1212 in forum Yamaha PWC Performance (2-stroke)
    Replies: 34
    Last Post: 08-11-2013, 08:35 AM
  2. Losing RPM - 2008 RXP 255, 2012 RXP 215, 2013 GTX 155
    By FlyboardAlberta in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-22-2013, 10:09 PM
  3. Losing RPMS?????? Check Wave Eater Couplers for Wear
    By smacota1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-17-2011, 11:28 AM
  4. Losing RPM on SHO
    By samerone in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-20-2011, 05:18 PM
  5. Losing RPM via Jetworks?
    By Chrisrokc in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-01-2007, 01:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •