Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Crawfish Eating Tutor... aceofd1amonds's Avatar
    Join Date
    May 2007
    Location
    Galveston, Texas
    Posts
    44

    Question, and new results!

    First the results:
    PPK
    Jetworx
    Jims Plate
    1200 Grate
    tighten the loose throttle cable upgrade
    1/2 tank of fuel

    ...

    70.1mph supermanned!

    Which is better than my last 69.5! Just running better today i guess!


    Now for my question. After i got the jetworx and pump plug kit, i notice a high pitched whine when i take off slowly. Just for a second. I dont know if maybe the impeller is ringing off the wear ring or something like that? i dont know if this is normal or not. Please advise.

    -Kade


  2. #2
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by aceofd1amonds View Post
    First the results:
    Riva Power filter
    PPK
    Jetworx
    Jims Plate- technically its an old school Riva 1200 plate, with Jims FF mod and a little WFO magic
    1200 Grate
    tighten the loose throttle cable upgrade
    1/2 tank of fuel

    ...

    70.1mph supermanned! awesome !

    Which is better than my last 69.5! Just running better today i guess!


    Now for my question. After i got the jetworx and pump plug kit, i notice a high pitched whine when i take off slowly. Just for a second. I dont know if maybe the impeller is ringing off the wear ring or something like that? i dont know if this is normal or not. Please advise.

    -Kade


    I dont think so. Still the stock prop, and the liner had a little wear.

    I dont know on that one Kade. Call you later.

  3. #3
    Crawfish Eating Tutor... aceofd1amonds's Avatar
    Join Date
    May 2007
    Location
    Galveston, Texas
    Posts
    44
    still no ideas on that little whining noise? I should note that it goes away after i ride through its frequency (rpm level)....

  4. #4
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by aceofd1amonds View Post
    still no ideas on that little whining noise? I should note that it goes away after i ride through its frequency (rpm level)....
    Kade

    I will be in Beaumont this weekend if you wanna come ride Sunday.
    We could listen to it then ?

  5. #5
    Crawfish Eating Tutor... aceofd1amonds's Avatar
    Join Date
    May 2007
    Location
    Galveston, Texas
    Posts
    44
    wish i could, but ive got to work. Im sure it'll be fine. If something flys off, or catches fire, we'll know we've got a problem.
    -Kade

  6. #6
    That type of noise is usually the pump bearings going out. Remove the pump and spin it by hand and see how it feels.
    Last edited by Fercho; 07-15-2007 at 11:54 AM.

  7. #7
    Crawfish Eating Tutor... aceofd1amonds's Avatar
    Join Date
    May 2007
    Location
    Galveston, Texas
    Posts
    44
    what happens when they are ruined?

  8. #8
    Dave Sharp dav_dman's Avatar
    Join Date
    Aug 2005
    Location
    louisville Ky/so. IN
    Posts
    1,453
    +1
    1

    agree with fercho

    Quote Originally Posted by aceofd1amonds View Post
    what happens when they are ruined?
    you have the whine...sounds like an in tank fuel pump in a car going out.. and you have what feels like the prop slipping on the driveshaft when you first launch at the ramp.. it'll slip and slingshot you a couple times then it's fine the rest of the ride.. except it's loading the engine..

    i had no rpm loss..just the above and my engine ran slightly hotter. I pulled it apart and water poured out of my pump brgs. Fixed it properly , corrected the cause, and whine went away. Chk'd my pump last week (after last yrs rebuild) and it's perfect.

  9. #9
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450

    Pump noise

    Its possible, but I had the pump out a couple of times and they felt fine.

    Kade call me when you get a chance

    And speaking of pump noises... call me Fercho

  10. #10
    Crawfish Eating Tutor... aceofd1amonds's Avatar
    Join Date
    May 2007
    Location
    Galveston, Texas
    Posts
    44
    I called you 2x this week. once i got a voicemail and the other time it rang out to voicemail. i think i even left a message. gimme a call this week if you dont mind.
    Thanks,
    Kade

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New 94 Waveblaster questions and help
    By bmoreblaster in forum Yamaha Old School Skis
    Replies: 6
    Last Post: 11-04-2010, 08:44 AM
  2. Help upgrading oiler in PTO and question on new X-charger?
    By awague2 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-03-2010, 12:21 AM
  3. New,questions and problems
    By morespeedplease in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-02-2010, 09:34 PM
  4. RPM question first time out on green wheel and new prop
    By turbojamie in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-08-2009, 07:10 PM
  5. R&D girdle and new ride plate question
    By Turbo Nick in forum 4-Tec Performance
    Replies: 26
    Last Post: 01-05-2009, 02:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •