Results 1 to 7 of 7

Thread: RPM's

  1. #1
    rxpfun's Avatar
    Join Date
    Nov 2005
    Location
    Panama City, FL
    Posts
    186

    RPM's

    Fosters just posted a similar situation on the board, but this has me concerned. Last time out I did not see more than 7950 RPM's the entire day, Cold water, cold air, full tank all the way to an empty tank 7950. Any thoughts on this...does it sound like clutch slip?

    rxpfun


  2. #2
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    check the impeller first for dings....

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,429
    +1
    177
    No, it sounds more like a wear ring, or prop blades need a little less pitch. also check your oil level when hot, and should be in the middle of the 2 bends.

  4. #4
    rxpfun's Avatar
    Join Date
    Nov 2005
    Location
    Panama City, FL
    Posts
    186
    Thanks guys for the input, I should have also noted the ski has 24 hrs on it and has not been exposed to any shallow waters or water loaded with debris. If it still sounds like a prop/wear ring issue, thats where I'll look first.

    rxpfun

  5. #5
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    it does

  6. #6
    Quote Originally Posted by rxpfun
    Thanks guys for the input, I should have also noted the ski has 24 hrs on it and has not been exposed to any shallow waters or water loaded with debris. If it still sounds like a prop/wear ring issue, thats where I'll look first.

    rxpfun
    you`d be surprise at how soon you could score the wear ring. They usually last around 20-40 hours... with moderate to heavy use...PR...

  7. #7

    Join Date
    Jul 2005
    Location
    Lake Dunlap, Texas
    Posts
    1,582
    +1
    25
    RXPFUN--love your flag I would like to do the same but dont know how to do it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXP noise @4750-4900 RPM's
    By RXPNJ in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-12-2010, 12:54 AM
  2. RXP RPM Limiting Question
    By Jarrett in forum 4-Tec Performance
    Replies: 40
    Last Post: 07-20-2007, 06:58 PM
  3. Can high heat and humidity take away 200 rpms?
    By Vern in forum 4-Tec Performance
    Replies: 14
    Last Post: 06-08-2005, 12:46 PM
  4. What should stock RPM be running?
    By Compwhiz82 in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-27-2005, 04:25 PM
  5. Replies: 1
    Last Post: 05-18-2005, 07:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •