Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 51
  1. #1
    flyboy's Avatar
    Join Date
    Nov 2005
    Location
    Destin, FL
    Posts
    1,585

    just finshed breaking in the new motor

    broke her in, put about 1.2 tanks through her. ran STRONG! trim tabs on, 1200 grate, rough water.

    7100 RPMs at 76.7

    the testing has begun...


  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23


    SWEET ! this a 1300 or 1400 ?

  3. #3
    thesepaperwings's Avatar
    Join Date
    May 2007
    Location
    South East Kansas
    Posts
    1,283
    +1
    1
    I thought I had a fast ski untill I read this. Nice work

  4. #4
    flyboy's Avatar
    Join Date
    Nov 2005
    Location
    Destin, FL
    Posts
    1,585
    T. Judge ported 1390 EFI. still a bunch of things to look at, but she's runnin

  5. #5
    Never say never KirkF350's Avatar
    Join Date
    Jun 2005
    Location
    Midlothian, Texas
    Posts
    4,433
    +1
    3
    Congrats. I think you are going to have a monster on your hands.

  6. #6
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,800
    +1
    449
    Nice work James.

    Keep an eye on your test pilot. He hasnt ridden a fast ski in a while, and you dont want him to come flying off.

  7. #7

    Join Date
    Apr 2006
    Location
    South MS
    Posts
    1,095
    Quit sandbaggin and tell everyone what it really runs....haa Congrats
    Now I got to work on mine so we all can go ride soon.

  8. #8
    flyboy's Avatar
    Join Date
    Nov 2005
    Location
    Destin, FL
    Posts
    1,585
    Quote Originally Posted by WFO View Post
    Nice work James.

    Keep an eye on your test pilot. He hasnt ridden a fast ski in a while, and you dont want him to come flying off.
    He said he almost lost it when he gave it gas, might need to duct tape his hands to the bars

  9. #9
    Awesome, welcome to the BB EFI club...

  10. #10
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Quote Originally Posted by flyboy View Post
    He said he almost lost it when he gave it gas, might need to duct tape his hands to the bars


Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Finally breaking in the motor after the engine work
    By 1200 stx-r in forum Yamaha PWC Performance (2-stroke)
    Replies: 57
    Last Post: 06-20-2011, 06:29 AM
  2. Break in on new motor?
    By Tturbonegro in forum 2-Stroke Performance
    Replies: 9
    Last Post: 05-26-2011, 12:35 PM
  3. New to this. Have question about breaking in the engine.
    By james1 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-08-2009, 09:05 AM
  4. Scott and I Breaking in his new Race Motor
    By sixtydashone in forum Jersey Riders
    Replies: 5
    Last Post: 10-04-2008, 10:34 PM
  5. Does anyone know how the engine break in on new RXP works?
    By dre23 in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 01-29-2006, 12:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •