Page 1 of 10 1 2 3 ... LastLast
Results 1 to 10 of 100
  1. #1
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4

    Revamping the 99 SLX w/ your help

    New-to-me ... 99 Polaris SLX with 64 hours

    Symptoms:

    Holeshot leaves ALOT to be desired. Sometimes it struggles to get on plane. Sometimes it does nothing when you nail it WOT. It i kinda whack the throttle and pump it a few times it wakes the motor up and then on the 5th pull it pulls pretty good.

    I can hold the throttle let's say 1/2 throttle.. just be going along at first, then once it gets going you feel a second wind of power just kick in and the machine starts pulling and going faster without applying more throttle... just smooths out and picks up power and speed after a few seconds of holding it at that throttle position.

    these sound carb related? ... this is where it'll get fun, i have ZERO carb experience, only fuel injection. What can i say, i was born in 1985

    Top speed on the speedometer was like 54mph @ 6210 rpms

    If I am going WOT for a few miles, then kinda slowly let off the throttle and take it off load, it stalls out sometimes. In a 1.5 hour period of riding, it probably stalled about 10 times on me... never at idle and never at WOT... only at cruising it would stall out.

    I'm running BR8ES spark plugs. decent? ok? wrong plug? better plug recommended?

    Have a vibration somewhere pretty bad if the machine is hooked up on smooth water, the machine feels smooth, but when you are bouncing across chop, everytime the ski gets unhooked it's got a pretty intense vibration


    I've always admired the Polaris section of the forum as a spectator on the Seadoo side, but now I'm actually pretty excited about this ski I have. It was cheap enough, good condition, and i have a very open mind to the machine and hope to get it running like some of you say this machine is capable of. Look foward to picking all u guys' minds

    Gonna work on the ski a bit tonight, so if there's things you can think of i should check and inspect or remove, let me know.... if there's something in my list of symptoms you recommend I'd be happy to hear suggestions.

    Thanks in advance!

    STEVE


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    It sound's like to me that your pump bearings need to be looked at. Some of your symptoms sound carb related and/or pump. Pull the pump and have a look/see...

  3. #3
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu. Live In Los Angeles.
    Posts
    841
    Maybe the accelerator pumps on the carbs are not working?

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Pull the carb rack and clean them internal carb filters.

  5. #5
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    where do i find the accelerator pumps... and how can i find out if they are working?

    i am going to pull the pump out right now and see what i find... thanks for that diagram beerdart!

    i'm going to put in some long hours on it right now, so any help and steps and procedures or diagrams are more than helpful!

  6. #6
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    ok Al... i'll pull the carb rack tonight as well... i need total rebuilds? or just pull them apart and look for internal filters and clean them out?

    like i said, i'm a sad sad newbie to anything carbureted, lol... so does cleaning internal filters mean a compelte rebuild of them?

  7. #7
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Steve,
    you got some Polaris guru's in your area. Buy them the frosties, and have them school you a bit.

    The Polaris is a strange little boat, with many little gotchas... once you learn them, you can't believe how easy it is.

    Lot's of cool items stock:
    SST pumps and props.
    Hydroturf stock.
    O-ring'd heads that you can inspect fairly easily.
    Carb access is sweet.
    Hull is tough as NAILS. (dropped my SLX on concrete, and dented the concrete)
    Gauge package (when it works, is top notch)
    Speedo actually is fairly close.
    Fast on smooth, dangerous in the rough.
    Nothing jumps better.

  8. #8
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    You probably won't need any carb kits, just a few items IF anything. Those filters catch a lot of crap and will certainly create your type of complaint.
    The carb R/R is a piece of cake. Mark the hose locations and the rest is self explanatory. Make sure the return restrictor is clear as well.

  9. #9
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    okedokes.... attacking the carb rack as we speak... not that i know wtf i'm doing, but i'm taking my time seeing what is what. just a few bolts, and disconnect a fuel line or two and it should all come out together.

    i'll check back after the rack is out... then i'll probably pull the pump

  10. #10
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Location
    Minneapolis, Mn.
    Posts
    2,008
    +1
    5
    The domestic engine does have a normal vibration that occurs down around the 2500 rpm range but should be short lived. Something that might be causing the extra vibration would be a broken or cracked motor mount...so I would check those as well. Like others have said, check the carbs...with that age of watercraft things need to be gone through, even if it's just to find out what condition they are currently in. Also like others have said, take the pump apart as it's very easy to do and could shed some light on some of the other issues you mentioned.

    P.S. Big warning...you should be running BPR8ES spark plugs...get those others out of there!!!!
    Last edited by 32DegH2O; 07-09-2007 at 08:08 PM.

Page 1 of 10 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 07-13-2015, 09:34 PM
  2. 99' SLX 1050 pump help
    By electricgeoff in forum Polaris Open Discussion
    Replies: 2
    Last Post: 04-23-2011, 02:44 PM
  3. Ignition update kit on 99 SLX......Where do the different wires go?
    By Fandini in forum Polaris PWC Performance
    Replies: 6
    Last Post: 07-12-2010, 06:57 AM
  4. Carb help on '99 SLX
    By SideFX in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 07-21-2008, 07:30 PM
  5. Q: about the '99 Polaris SLX
    By SideFX in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-06-2008, 02:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •