Results 1 to 8 of 8
  1. #1

    Waterspout question

    I've got a 94 Raider 700. Is it supposed to have the goofy waterspout that shoots up in the air?


  2. #2
    old school big raider's Avatar
    Join Date
    Sep 2006
    Location
    dallas,tx
    Posts
    1,423
    yes its actually called a visibility spout-indigenous to yamaha watercraft- mark

  3. #3
    So if mine's not doing it that means something's wrong/clogged?

  4. #4
    cheatin' piston popper addicted's Avatar
    Join Date
    Jul 2006
    Location
    north jersey
    Posts
    6,188
    +1
    176
    The hose might be clogged or removed. I hate that thing, and there is no ill effect to removing it.

  5. #5
    qbzonk's Avatar
    Join Date
    Aug 2006
    Location
    Orlando
    Posts
    975
    mine's blocked off. I hate those pissers.

  6. #6
    Cool. Knowing that its supposed to have it, I looked at it and found whats disconnected. Thanks guys!

  7. #7
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    mine is plugged and i have the hose removed. they're no good looks better w/o it.

  8. #8
    CatRunner's Avatar
    Join Date
    May 2007
    Location
    Los Angeles, Sunny Calli
    Posts
    115
    I removed my "visilibilty spout" and modified it so that it would blow out though my jet-pump......>> for an increase in thrust and top-end speed!...... haha!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  2. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  3. Oil Level question , this thing mixes me up :(
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-23-2005, 10:03 AM
  4. Question for the Hulk
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-20-2005, 07:13 AM
  5. RXP VTS Question
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •