Results 1 to 3 of 3
  1. #1

    finally on the water.

    well I finally got my rxp on the water with riva stage 3 sc 42# injectors and jfizzle's ic. still need to get a new prop ordered but I'm lazy what can say! but even without it, it hauls. so the lake i was on was pretty choppy I landed her hard a few times and when I got home I did a little inspecting of the hull and found my gell coat has started to spiderweb With all this hull delamination talk should I be worried? theres no chips in it anywhere.

  2. #2
    cbrich's Avatar
    Join Date
    Nov 2006
    Around Lake Travis
    I think the spiderweb cracks is what you need to worry about. I have chip in my gelcoat, but no spiderwebs.

  3. #3

    Join Date
    Jul 2006
    Acworth, GA
    I think you've got that backwards... just about every RXP on the water has SOME spider webbing... you just need to look closer

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Finally saw a Kaw 250 on the water.
    By NCHeel in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-12-2007, 08:10 PM
  2. Finally got the RXP on the water
    By DooVa in forum 4-Tec Performance
    Replies: 30
    Last Post: 04-16-2007, 08:25 PM
  3. Finally on the water!
    By The Bandit in forum 4-Tec Performance
    Replies: 89
    Last Post: 04-04-2007, 09:25 AM
  4. the water!!
    By sourpower RXT in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-30-2006, 01:58 PM
  5. Finally in the water
    By Sunfunzoom in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-09-2005, 08:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts