Results 1 to 4 of 4
  1. #1
    fabrication guru rapidacceleration's Avatar
    Join Date
    May 2005
    Location
    Lake Travis austin, TX
    Posts
    1,156
    +1
    2

    im trying to find the seal that is in the pto cover

    im trying to find the seal that is in the pto cover but not having any luck.
    ive now ordered just about every seal on the pto housing fiche with little luck. the one i need is where the driveshaft plugs into the cover. right behind the bellow & berring seal. ill post pics of the seal tonight if need be, but im telling ya ive looked and looked but its not on the fiche.
    its the only thing keeping me from installing the driveshafts again.
    anyone have a clue or better yet a part number???


  2. #2
    are you talking about item number 11? the seal between the drive shaft and the crank snout? if so the part number is 420630550.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	crank_528.jpg 
Views:	107 
Size:	26.0 KB 
ID:	2231  

  3. #3
    fabrication guru rapidacceleration's Avatar
    Join Date
    May 2005
    Location
    Lake Travis austin, TX
    Posts
    1,156
    +1
    2
    thanks mark
    i think that might be it. is there a special removal tool to pop it out without removing the pto cover again??
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	seal_415.jpg 
Views:	101 
Size:	28.7 KB 
ID:	2240  

  4. #4
    yes thats the one(#11) just take it out with a pick. it sits in a groove in the pto snout of the crank. its just a rubber seal. it has no metal reinforcement so it is pliable. comes out easy

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 11-07-2015, 11:20 AM
  2. Replies: 24
    Last Post: 08-15-2009, 02:32 PM
  3. trying to find an englishman who goes to lockview motel
    By jetskibill9999 in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 05-14-2009, 05:17 PM
  4. 250x ultra,have anyone try to repitch the impeller?250
    By XRIDER in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 05-01-2007, 02:13 PM
  5. Trying to install the ATM boost guage
    By Phil in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-13-2005, 11:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •