Results 1 to 2 of 2
  1. #1
    just GOT TO DO IT! great lakes gpr 1200's Avatar
    Join Date
    May 2006
    Location
    muskegon michigan
    Posts
    798

    94 xp blowing 5 amp fuse

    I am working on a freinds 94 xp that blows a 5 amp fuse as soon as the battery is connected. I just started looking at it. and Don't know much about it at this point. Is this a common fault on old seadoos? I did a search and came up with the Vts fault but the 94 does not have VTS? any help?


  2. #2

    Join Date
    May 2007
    Location
    Northern VA
    Posts
    85
    most likely its a bad mpem

    check the stator to see if its grounded, if not, mpem

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 XP Limited blowing 5 amp fuse
    By boostcrazy99 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 08-27-2016, 01:11 PM
  2. 1999 GSX Limited blowing 15 amp fuses
    By chazdo2 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 09-13-2010, 07:50 AM
  3. still blowing 15 amp fuses?????
    By clownhands in forum 2-Stroke Performance
    Replies: 14
    Last Post: 11-11-2009, 10:14 PM
  4. blowing 5 amp fuse
    By maytagman in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-04-2008, 08:55 PM
  5. 1992 sp blowing 5 amp fuse
    By Pete-n-sara in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 10-28-2007, 03:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •