Results 1 to 10 of 10
  1. #1

    2873091 stator install

    K, got it today, got everything removed, installing it now, removingh oil injection while I am at it. Anyway, theres no instructions with this updated kit. Is it just plug and play where the old stuff come from or is it a little different? If someone could let me know about the wiring, that would be awesome.


  2. #2
    match all wire colors and you should be good to go.

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Install directions are in the tech section under Domestic Electrical, post 9 if my memory serves me right.

  4. #4
    Oki everything is going smooth so far, I am getting stuff put back together. Since I went with the updated CDI and Stator, Should I leave the flywheel cover off and take it in to a shop tomorrow to have the timing done on it? I'd rather not ruin a gasket. I havnt messed with the 2 screws that were adjustable on the flywheel, as I believe that adjusts the timing. Anyhow, lemme know

  5. #5
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    You should be fine, put it together and check the timing after you get her running.
    You can go through the tech section Engine Domestic and check for static timing and see how it matches up.

  6. #6
    Ok, I got everything together, and I am still getting no spark. Also, I have 5 gallons in it, My red light keeps blinking and says fuel, Is that why its not getting spark?

  7. #7
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    The red light due to low fuel will just "limit" the RPM's but it should run.
    Is the battery fully charged?
    What is the battery voltage when cranking the engine?

  8. #8
    www.springbreak-florida.com rgard32's Avatar
    Join Date
    Dec 2006
    Location
    Saint Petersburg,Florida
    Posts
    665
    take a pic of your electrical box if u can and post it up here......

  9. #9
    Oki guys. Got this baby running. I push the start button and it starts in less than 3 seconds. Runs like a raped ape also. Puts my dads tigershark 770 to shame, and he has a bunch of stuff done to it. The problem with the no spark after stator/CDI install was I missed a ground wire on the CDI. One problem I do have tho is the carbs I think. It gets to where it bogs down sometimes, give it full throttle and it clears up, happens alot. Sometimes it dies and is hard to start, HAVE to use the choke to get it back up. Dirty carb filters?
    I also have a few questions for it tho.

    I removed the oil injection, what should I use? Right now I have yamalube but I'd like to find something less than 35.00/gallon Any suggestions?

    I dont think the trim is working correctly, The trim rod was missing when I bought it, but I have a piece of allthread temporarly on it till the factory piece comes in, Is this ski just hard to turn the wheel when doing 50+? I feel resistance at high speeds, low speed is no resistance.

    What should I do about the trim motor? It just not moving, so I had to set the umm, Plastic piece that moves up and down for the trim, right in the middle, also is that where it should be if it doesnt move or should I tilt it up or down?

    I am thinking about getting a prop and ride plate, whats the best for me? I live in Oklahoma and we got nothing but lakes, so no large waves. when mine does grab water, it flies, but it hits alot of small chop and slows it down alot, any suggestions? I'm sure anything over stock is better. I'd like a nice balanced setup.

  10. #10
    BTW, I couldnt have done my install without this link.
    http://greenhulk.net/forums/showthre...ghlight=stator

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Polaris SLX 1200 stator install question
    By parryc13 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-28-2015, 02:40 PM
  2. how can i tell if i have updated stator installed on my polaris slt700 1996
    By adkinsmatthew in forum Polaris PWC Performance
    Replies: 18
    Last Post: 07-15-2012, 01:00 PM
  3. Stator Installation?
    By call0300 in forum Yamaha How To & FAQs
    Replies: 3
    Last Post: 04-26-2010, 02:46 PM
  4. Stator Removal/Install Kit
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 47
    Last Post: 04-01-2008, 04:19 AM
  5. installing a stator?
    By gorilla03 in forum Polaris How To & FAQs
    Replies: 19
    Last Post: 09-01-2007, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •