Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 41
  1. #1

    Join Date
    Apr 2005
    Location
    San Diego
    Posts
    135

    2004 Rxp Blew Up ??

    I was on the lake yesterday everything was going fine then I went from 7500 RPM to 0 instantly. I just had green hulk install metal washers and ceramic washers. I dont have a clue what went wrong. I tried to start it and it wont turn over, just clicks. Just installed new battery. Please help


  2. #2
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    Does the starter spin at all, or just clicking?
    Do you have any error codes after hitting set 5 times?

  3. #3

    Join Date
    Apr 2005
    Location
    San Diego
    Posts
    135
    no error codes.

  4. #4
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    did it make a noise?

    take the plugs out and look for damage

    and best case look in the pump and make sure ( hope ) it is jamed

  5. #5
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    i would start with removing the pump. If it is ok then try turning the motor by hand, just keep getting deeper and deeper until you find the problem.

  6. #6
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    pull the pump and remove all 3 spark plugs and tap the start button... start there and then report back with your findings

  7. #7
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Ever had a ceramic washer failure?

  8. #8
    JAG's Avatar
    Join Date
    Feb 2006
    Location
    Richmond, VA
    Posts
    1,026
    this is exactly what happened last time I was on the water with my 05 RXP! What happened??? The cam chain broke...

  9. #9

    Join Date
    Apr 2005
    Location
    San Diego
    Posts
    135
    Quote Originally Posted by JAG View Post
    this is exactly what happened last time I was on the water with my 05 RXP! What happened??? The cam chain broke...
    Damn I hope thats not the problem! Thanks Shibby Ill do what you said maybe theres something I overlooked in the pump. I never had a ceramic failure, had metal washers and ceramic bearings installed by the man himself. Thanks for the help everyone, want to look at every possible problem before taking it to a dealer. Luckily a purchased an extended waranty. Any one else had this problem please chime in

  10. #10

    Join Date
    Apr 2005
    Location
    San Diego
    Posts
    135
    How hard is it to replace cam chain? Is this covered by waranty?

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upgrade options for my 2004 RXP Steering set-up
    By suisid2 in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-04-2013, 08:12 PM
  2. 2004 RXP Motor locked up
    By slow02gt in forum 4-Tec Performance
    Replies: 30
    Last Post: 08-07-2013, 09:37 PM
  3. 2004 rxp not hooking up
    By martin_7238 in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-20-2010, 04:47 PM
  4. Bought a 2004 RXP Locked up motor.a few ??
    By spinyard in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-15-2008, 02:17 PM
  5. Need advice to hop up 2004 RXP
    By stonylake rxp in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-06-2006, 09:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •