Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 41
  1. #1

    Am I down on power? 03 gtx sc 4 tech

    rode this craft yesterday after replacing a chewed up 12/20 impeller with a solas 12/20 and new wear ring. craft turns 6600 rpm and in the mid to high 50's on mph on gauge. is this right? mechanic says super ok as he checked it by hand when he put on a BOV for me. 185hp 4 tech. oil appears to be not overfilled after pulling out a quart or so. new plugs. when I hook up the key I get a flashing indicator on the dash saying maint a few times them shuts off. anyone? runs ok just do not know what to expect. 52 hours on craft. thanks in advance for your help. sea level san diego bob
    Last edited by caflashbob; 07-14-2007 at 10:18 AM. Reason: added elevation


  2. #2
    Rushhour's Avatar
    Join Date
    May 2007
    Location
    Liberty, IL
    Posts
    7
    Let me start off by saying I that have very little experience dealing with PWC's, but I do have an 03 GTX SC. I got mine at the beginning of June, and it had approximately 58 hours on the ski. The top speed, according to the speedo., has been 61mph.....but typically it is in the mid to upper 50's, depending on the conditions.

    I am not a huge speed freak, so I have never had the actual speed measured via gps.

  3. #3
    cbrich's Avatar
    Join Date
    Nov 2006
    Location
    Around Lake Travis
    Posts
    1,374
    +1
    1
    Since you are only 6,600 rpms read the article to the left called SC Clutch Failure

  4. #4
    Mentally Unstable dochere195's Avatar
    Join Date
    Jun 2007
    Location
    Algonquin, IL
    Posts
    174
    Yes, your running low...

    Is this the first you rode this craft, if not, what were your numbers before? Why the BOV?

    At 6600 rpm it sounds like the SC washer issue as stated above but this could also be a boost leak issue and/or it could be a poor bov install or a faulty bov.

  5. #5
    Quote Originally Posted by dochere195 View Post
    Yes, your running low...

    Is this the first you rode this craft, if not, what were your numbers before? Why the BOV?

    At 6600 rpm it sounds like the SC washer issue as stated above but this could also be a boost leak issue and/or it could be a poor bov install or a faulty bov.
    yup!...PR...
    the bov leaking boost?

  6. #6
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Everyone saying washers remember it does not have an intercooler. I don't know what rpm's it should turn so it's hard to say.

  7. #7
    Quote Originally Posted by NCHeel View Post
    Everyone saying washers remember it does not have an intercooler. I don't know what rpm's it should turn so it's hard to say.
    7600-7650max...PR...

  8. #8
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    So what would be the max rpm's for a non ic/sc 4-tec engine? That's what the GTI's hace correct?

  9. #9
    near as I can figure out my buddy that got this boat from ground up the stock impellor/pump/wear ring a couple of years ago and took it to the local arizona shop and they said put the 04 metal pump and they had a solas concord impeller in stock with 12/20 pitch. I just talked to him and he said that slowed it down after that where it was no longer faster than the honda turbo that he also had whereas it used to pull the honda before. this sc appears to be over propped as it cannot reach the rev limiter at all and is missing the last thousand rpm where the max power according to the manual is at 7300 versus a 7600 rpm redline and it only gets to 6600. is the factory original prop a 3 or 4 blade as the solas is a four blade and is the original pitch 11/19? will the stock oem impeller from the 03 fit the 04 metal housing. the 12/20 solas I replaced appears to be 155mm? did not measure it exactly. any help would be nice. I seem to need the lower pitch prop to let the motor rev to its hp peak as it cannot get there now. bob

  10. #10
    Quote Originally Posted by caflashbob View Post
    near as I can figure out my buddy that got this boat from ground up the stock impellor/pump/wear ring a couple of years ago and took it to the local arizona shop and they said put the 04 metal pump and they had a solas concord impeller in stock with 12/20 pitch. I just talked to him and he said that slowed it down after that where it was no longer faster than the honda turbo that he also had whereas it used to pull the honda before. this sc appears to be over propped as it cannot reach the rev limiter at all and is missing the last thousand rpm where the max power according to the manual is at 7300 versus a 7600 rpm redline and it only gets to 6600. is the factory original prop a 3 or 4 blade as the solas is a four blade and is the original pitch 11/19? will the stock oem impeller from the 03 fit the 04 metal housing. the 12/20 solas I replaced appears to be 155mm? did not measure it exactly. any help would be nice. I seem to need the lower pitch prop to let the motor rev to its hp peak as it cannot get there now. bob
    in one way yes, the props from 03 to 04 (which a 12\20 would be stock solas replacement) slight changes were from vendors and manufacturing. BRP changed the design slightly, less of a straight edge per say.
    your ski tho should be running full steam with that solas 12\20.
    I`m more inclined to say, check your SC, in 03 they used metal washers and yours may be slipping which was very common. the 03 prop should fit in the metal housing. they are both 155mm. I would also remove the newly installed BOV, you may have a boost leak. to eliminate one item recently installed. You can not really check the slip moment of the SC clutch simply by hand, you have to measure it with a torque wrench the proper way...try removing the BOV first before anything else, 2nd check slip moment of SC before you start swapping props again...
    the original pitch of factory prop should be 11\23 if I remember correctly...hope this helps you find your problem...PR...

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva power filter question on 03 GTX sc
    By rafelos1337 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-12-2012, 05:58 PM
  2. Just ran my 03 gtx sc on the gps, what do you think?
    By super_gtx in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-18-2008, 11:17 PM
  3. 12/20 best for low end on a 03 gtx sc?
    By lextoy in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 10-31-2007, 05:22 PM
  4. 03 GTX SC, what size allen head on impeller?
    By gbest in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-11-2007, 02:33 PM
  5. Depth finder on a 03 GTX SC
    By eckersjc2 in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-01-2007, 12:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •