Results 1 to 3 of 3
  1. #1

    Angry 2004 Polaris msx 150 plugs turned silver after ten minutes help

    Just took the machine to get new plugs and oilchange , however I started the machine it only ran ten minutes . I got a friend of mine to check the plugs for me and discovered that the plugs were covered with silver metallic colour liquid substance ..any suggestions he told me that the engine was gone ..The dealer never did mentioned this when I picked up the machine .

  2. #2

    Join Date
    Oct 2006
    Beaver Falls, PA
    any photos of the plugs?

  3. #3
    barefootpolaris's Avatar
    Join Date
    Jan 2007
    Western. NC
    Could be sludge, but dont think I have ever seen a pure silver colored liguid come out of the motor. Usually if the motor is blown it will have a heavy metal flake, but not liquid. Pics would help though.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 07-18-2012, 08:22 PM
  2. 2004 polaris msx 150
    By gtile04 in forum MSX/Matrix
    Replies: 9
    Last Post: 11-13-2009, 09:45 AM
  3. 2004 polaris msx 150
    By gtile04 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 11-08-2009, 10:09 AM
  4. 2004 Polaris msx 150 ecm and match injectors
    By gvnitup in forum Polaris Classifieds
    Replies: 1
    Last Post: 08-01-2009, 12:30 PM
  5. 2004 Polaris MSX-150 4 Stroke - 23 Original Hours - Full Part Out
    By seatsR4toilets in forum Polaris Classifieds
    Replies: 6
    Last Post: 02-14-2009, 05:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts