Results 1 to 3 of 3
  1. #1
    ( Had to go RXT.....Baby) Ultra Junkie's Avatar
    Join Date
    May 2007
    Posts
    94

    Talking Need 250X Help - Having Issues....

    Ok - I need some help.... Ski was running GREAT.... I then started hearing a strange knocking possibly from the pump area - bearing maybe - stopped and checked for anything stuck in the pump - all looks good - just to be safe I idled it back to shore and pulled the seats - There is a hose that goes from the intercooler to the throtle body that was almost off the intercooler and kinda crimped - slide it back to normal position and tightened the hose clamps - While I was doing that, I notice there is quite a bit of oil in the engine area - more of just a light film - also noticed the pre-filter on the Riva Performance Intake Filter had quite a bit of oil on it (How is that?) - Checked plugs and they were fine - Ski just hit 10 hours so probally time for an oil change which I will do Monday - Is the oil film normal inside the engine area? I pulled the oil catch can and it didn't have much in it, pulled the small bypass hose off that goes to the cooler above the large hose that was loose going to the throttle body and it had traces of oil in it - this oil everywhere thing has me concerned a bit but then there is the knocking noise that I don't know where it is comming from either. After checked all of the above I put it all back together and started it - all sounds fine - rode it and all seemed fine but after about 5 minutes the knocking was back - and it seems to knock more during idle which is when I notice it the most - Could it be the S/C bearings, pump bearing - any ideas?

    And last but not least - After pulling the ski out - I noticed a slight coating of a black grease on the inside of the exhaust on the silver tubing - not real bad however I have never had a 4 stroke so I didn't know if the was normal or not?

    Any help from you guys would be greatly appreciated...

    Thanks in advance.


  2. #2
    Ok are you speaking of the red line from the intercooler.

    What you did is badly over heat your motor.

    Red line "pic" pinched makes for little or no water cooling the air from the SC.

    This hot air over heated the motor. Since your due for a oil change it for sure caused the oil and gas to expand and start blowing out the Catch can. Back flow can happen in these intakes when you let go of the throttle abruptly.

    The knocking is more then likely the cams hitting the valves.


    DONT RIDE IT UNTIL YOU DO A FULL OIL CHANGE WITH FILTER.

    It should quiet down then.

    I could be wrong but since it happened to me also Im pretty sure thats what it is.

    Change your oil.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	WaterRoute.JPG 
Views:	63 
Size:	1.48 MB 
ID:	31463  

  3. #3
    ( Had to go RXT.....Baby) Ultra Junkie's Avatar
    Join Date
    May 2007
    Posts
    94
    Quote Originally Posted by Skips313 View Post
    Ok are you speaking of the red line from the intercooler.

    What you did is badly over heat your motor.

    Red line "pic" pinched makes for little or no water cooling the air from the SC.

    This hot air over heated the motor. Since your due for a oil change it for sure caused the oil and gas to expand and start blowing out the Catch can. Back flow can happen in these intakes when you let go of the throttle abruptly.

    The knocking is more then likely the cams hitting the valves.


    DONT RIDE IT UNTIL YOU DO A FULL OIL CHANGE WITH FILTER.

    It should quiet down then.

    I could be wrong but since it happened to me also Im pretty sure thats what it is.

    Change your oil.
    Hey Skip,

    Actually the hose that had the small crimp is the 3 or 4 inch diameter hose that is about 6 inches long that goes from the cooler to the throttle body - is it possible that the water line going into the cooler is blocked somehow - which is what caused the over heat? Shouldn't I have gotten an over heat buzzer or something? It also seems that the knock is gone until the motor heats up. The water outlet on the front right side of the ski has a good discharge - I guess I should flush the cooler out as good as possible when I do the gas flush on it to get the oil out - With the 10 hours on it - think I should go Synthetic or stay regular - I don't mind doing the changes every 10 hours which was my original plan. And last but not least - what do you think about the black grease film on the exhaust outlet?

    Thanks for your help. Oh and by the way I did read your site about oil control and gunkin' up the intercooler - Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new ro 2 strokes have issue need help
    By primorxp in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-29-2014, 09:24 PM
  2. Replies: 6
    Last Post: 04-25-2012, 08:31 AM
  3. Replies: 0
    Last Post: 04-15-2012, 01:05 PM
  4. Need your help...Sportster Issues
    By svtjoe in forum Sea Doo Sport Boats
    Replies: 15
    Last Post: 09-18-2008, 03:19 PM
  5. HELP! need impeller help having to use stocker
    By Kinchyle in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-03-2006, 09:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •