Results 1 to 10 of 10

Thread: RPM Question

  1. #1
    Prism's Avatar
    Join Date
    May 2007
    Location
    "New" Jersey
    Posts
    826
    +1
    99

    RPM Question

    On a 1300 W/ fuel injection (no carbs or advent setup) What is the factory rev limit. Also, what are the max rpm's you can turn before a repitch is needed? Thanks. Alan


  2. #2
    Chrisrokc's Avatar
    Join Date
    Apr 2006
    Location
    Oklahoma City, OK
    Posts
    3,667
    I'm not sure what the limit is. I am sure WFO can answer that. You want your RPMS around 7150 though.

  3. #3
    Prism's Avatar
    Join Date
    May 2007
    Location
    "New" Jersey
    Posts
    826
    +1
    99
    Hey thanks, Mine are way too low in the heat. 6920. Was thinking about trying the stock impeller today, but I know its gonna be spinning way too fast. Carl said I would be down some RPM until more was done. Oh well, time to add more power!

  4. #4
    Factory rev limit is 7400 RPMs I believe.

  5. #5
    Robsauto2's Avatar
    Join Date
    Aug 2005
    Location
    Oceanside, CA.
    Posts
    774
    +1
    7
    Quote Originally Posted by Prism View Post
    Hey thanks, Mine are way too low in the heat. 6920. Was thinking about trying the stock impeller today, but I know its gonna be spinning way too fast. Carl said I would be down some RPM until more was done. Oh well, time to add more power!
    What speed on gps are you going at that rpm?

  6. #6
    injected2stroke's Avatar
    Join Date
    Feb 2006
    Location
    Taylor Mi.
    Posts
    255

    RPM's

    Are you running an 03 or an 05 pump with that 14/20? I was running that same basic set up for awhile but if your running an 03 pump I think you may have a little to much impeller. If your still running 03 pump I would try a 13/20 set back, with my old set up I was turning 7360 at 70+ mph.
    Last edited by injected2stroke; 07-16-2007 at 03:39 AM.

  7. #7
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by NateGP1300R View Post
    Factory rev limit is 7400 RPMs I believe.
    I believe this is right.

    I have spun up to 7350 before.

    I am sure Hibdon knows.

  8. #8
    Prism's Avatar
    Join Date
    May 2007
    Location
    "New" Jersey
    Posts
    826
    +1
    99
    Quote Originally Posted by Robsauto2 View Post
    What speed on gps are you going at that rpm?

    The day it was turning 6920 was a brutal day. Temp was over 95 degrees and humidity was near 100%. I still think I'm overpropped 6920 equaled 69.8 mph. On cool days/evenings with low humidity It turns 7080 at about 71.5, but those days are far and few between now that summer is here in full swing. Maybe I should fill the front bucket w/ ice before I ride!
    Last edited by Prism; 07-17-2007 at 01:12 AM.

  9. #9
    Prism's Avatar
    Join Date
    May 2007
    Location
    "New" Jersey
    Posts
    826
    +1
    99
    Quote Originally Posted by injected2stroke View Post
    Are you running an 03 or an 05 pump with that 14/20? I was running that same basic set up for awhile but if your running an 03 pump I think you may have a little to much impeller. If your still running 03 pump I would try a 13/20 set back, with my old set up I was turning 7360 at 70+ mph.
    I am running an 03 pump. I was thinking I might be able to switch back to the stock prop with the 85mm nozzle for awhile, but if you were spinning 7360 with a 13/20, I would definatly be spinning too fast. What if I bend the trailing edge of the stock prop? I'm planing on getting VFIII's shortly and upgrading to the 05 pump along with a head shave, so I'm trying to tweak what I have without buying a 3rd impeller. (plus its fun to experiment) Alan

  10. #10
    injected2stroke's Avatar
    Join Date
    Feb 2006
    Location
    Taylor Mi.
    Posts
    255

    RPM's

    I was running 7360 with a 13/20 set back but I had a riva nozzel and it was just over 88mm. had the same set up on another boat with a 87mm Yamaha nozzel was at 7250 rpms. I definately think you have to much impeller with your set up. I have a 13/20 set back like new for an 03 pump if your interested for a good price if not thats ok but I think it would be more suited to your needs. If your interested send me a PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RPM Question
    By Snoman in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-21-2006, 07:33 PM
  2. RXP First Ride...RPM Question
    By Teddy57 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-16-2006, 06:13 PM
  3. RXP First Ride....RPM Question
    By Teddy57 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-15-2006, 03:59 PM
  4. rpm question
    By brad2510 in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-20-2006, 12:45 PM
  5. RPM QUESTION
    By Carlos Miami RXP in forum 4-Tec Performance
    Replies: 46
    Last Post: 04-12-2006, 01:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •