Results 1 to 8 of 8
  1. #1

    Error code P-1202

    The check engine light came on while riding my 04 gtxsc today so I hit set 5 times and thats what it flashed. I have a riva stage 1 on it just for reference if that matters. Any ideas on what that means?


  2. #2
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    From the Seadoo manual:

    P1202 - "Oil tank pressure switch implausible or blow-by valve still closed"

    Possible cause:
    Damaged oil pressure switch, blow-by valve failure, damaged circuit wires, damaged connector or damaged ECM pins.

    Service Action:
    Check for 1.27 to 2.47 ohms between terminals.
    Check if TOPS is connected to wiring harness.
    Check resistance at 0 RPM and above 3500 RPM. At high RPM the resistance should be close to 0 ohm.
    Check for 12 volts on pin 1 of the blow-by valve.

    -----------------------------------------------------------
    May need to replace the TOPS valve. We've seen this error many times before.

  3. #3
    and how do I do all that? a more detailed descprition of where the parts are located would be great. thanks

  4. #4
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by mooneyb91084 View Post
    and how do I do all that? a more detailed descprition of where the parts are located would be great. thanks
    At the front of the engine you'll see the TOPS valve and the oil sensor. The TOPS valve is the little can with the green gasket and the oil sensor is under it sticking out at 90 degrees, with the large nut. I had to replace both on my GTX. In my case I replaced the oil sensor first, still had the code so I replaced the TOPS 2nd. Maybe if I'd replaced the TOPS first the sensor would have been okay. The TOPS is the "Turn over protection sensor" which stops the oil from draining into the engine when it's turned over.
    (Tks PR for Pic)
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	RXP intake stock IC 002.jpg 
Views:	3006 
Size:	630.4 KB 
ID:	31511  

  5. #5
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,282
    +1
    2
    I replaced this sensor also. It cost about 35-40 bucks. I havent had the code sense then!

  6. #6
    Quote Originally Posted by Rendog View Post
    I replaced this sensor also. It cost about 35-40 bucks. I havent had the code sense then!
    are you refering to the OSPS?...PR...

  7. #7
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,282
    +1
    2
    Quote Originally Posted by Pale Rider View Post
    are you refering to the OSPS?...PR...
    I bought the front and rear oil pressure switch. Only replaced the front and it fixed the problem!

  8. #8
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23

    Question

    I'm getting the P-1202 code. I'm gonna order both switches. Front and rear.

    question: is the front one more prone to going bad vs. the rear one?
    I've read a few threads where its mostly the front one. I'll order both to be safe.

    I checked the TOPS, and I hear it make its clunk/click sound when I connect my DESS and take it off. I hear when they go bad, it doesn't make that sound.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Got the 1202 error code
    By coreyallen in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-10-2014, 08:04 AM
  2. Who has gotten a P-0500 error code?
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-12-2012, 01:18 PM
  3. P-0500 error code??
    By BOOSTED in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-23-2010, 01:33 AM
  4. Sea-doo error code
    By stonylake rxp in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-18-2007, 10:27 PM
  5. Error code 1517 ????
    By ralphmalph3 in forum 4-Tec Performance
    Replies: 2
    Last Post: 03-10-2007, 11:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •