Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54

    Carbon Ring/Leak FYI

    my buddy had been having a leak on and off at the carbon seal for a bit now....i found out that water was getting in behind the prop splines and pushing the shaft forward up off the carbon seal creating the leak. I took the 4 pump bolts off and the pump back out by itself because of the water...

    i greased up the nose cone o ring and put a new seal on the pump the one around the wear ring...and i also checked the boot to make sure it was tight againts that metal flange, used just a dab of marine grease on the carbon ring and yesterday with 3-4 hrs of riding she was fine...

    last time out water was up to the SC..


  2. #2

    Join Date
    Jan 2007
    Location
    Pennsville NJ
    Posts
    109
    Quote Originally Posted by meeper View Post
    my buddy had been having a leak on and off at the carbon seal for a bit now....i found out that water was getting in behind the prop splines and pushing the shaft forward up off the carbon seal creating the leak. I took the 4 pump bolts off and the pump back out by itself because of the water...

    i greased up the nose cone o ring and put a new seal on the pump the one around the wear ring...and i also checked the boot to make sure it was tight againts that metal flange, used just a dab of marine grease on the carbon ring and yesterday with 3-4 hrs of riding she was fine...

    last time out water was up to the SC..
    There has been a thread on this by myeslf titled "help". I had to drill 2 holes in my nose cone.

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    This makes two in a week that i've heard about

  4. #4
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Quote Originally Posted by meeper View Post
    my buddy had been having a leak on and off at the carbon seal for a bit now....i found out that water was getting in behind the prop splines and pushing the shaft forward up off the carbon seal creating the leak. I took the 4 pump bolts off and the pump back out by itself because of the water...

    i greased up the nose cone o ring and put a new seal on the pump the one around the wear ring...and i also checked the boot to make sure it was tight againts that metal flange, used just a dab of marine grease on the carbon ring and yesterday with 3-4 hrs of riding she was fine...

    last time out water was up to the SC..
    So are you saying with the prop cone no leak, without it it was leaking?

  5. #5
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    no this prop i actually sold him and ran it no issues, i guess i didnt use enough grease on the splines to keep water out and it got in there and pushe the shaft forward, now the cone is still on because we do ride salt water time to time...

  6. #6

    Join Date
    Jan 2007
    Location
    Pennsville NJ
    Posts
    109
    Quote Originally Posted by Green Hulk View Post
    This makes two in a week that i've heard about
    As I said, when I was at the shop............a guy came in that just changed out his impeller and said he was leaking. By that time we knew the problem. I think this happens more then we realize

  7. #7
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Quote Originally Posted by meeper View Post
    no this prop i actually sold him and ran it no issues, i guess i didnt use enough grease on the splines to keep water out and it got in there and pushe the shaft forward, now the cone is still on because we do ride salt water time to time...
    gotcha

  8. #8
    , I`ve run the GTX with and without the cone and haven`t experienced this, what`s up? I read the thread and understand why, so how come all the ski`s don`t leak this way? even tho I run the stock rubber cone (which almost always comes off the aftermarket props in the first run) it`s just a matter of time before the grease gets washed out, but still no leaky...PR...

  9. #9
    75 mph on a budget TorquePhoto's Avatar
    Join Date
    Jul 2006
    Location
    Lake St. Clair, MI
    Posts
    360
    I am wondering the same thing Andy...I have been running coneless since
    Jerry posted about it way back when.....no leaks....(crosses fingers) But that is a purpose for the cone I never thought of.....if water were to fill the splines & empty space in front of the shaft it coul push the driveshaft forward & cause problems......I need to tweak the pellra again to get max RPMs and i am going to pack the hell out of it with grease!!!

  10. #10
    Quote Originally Posted by TorquePhoto View Post
    I am wondering the same thing Andy...I have been running coneless since
    Jerry posted about it way back when.....no leaks....(crosses fingers) But that is a purpose for the cone I never thought of.....if water were to fill the splines & empty space in front of the shaft it coul push the driveshaft forward & cause problems......I need to tweak the pellra again to get max RPMs and i am going to pack the hell out of it with grease!!!
    keep in mind that packing the slined cavity with to much grease will also have same effect hydraulically pushing the shaft forward when installing the pump...PR...

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replaced carbon ring still no thrust and has a leak?
    By joseph9936 in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-14-2016, 03:09 PM
  2. weird carbon ring wear causing water leak. Riva Stg 3 RXP
    By synergy141 in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-09-2015, 06:55 PM
  3. I've got the Carbon Ring Line, but no Leaks
    By yellow4 in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-07-2007, 09:31 AM
  4. Problems with carbon seal leaking-- possibly this instead...
    By VFX_Artist in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-20-2006, 09:49 AM
  5. Reinforcement of pump tunnel area around carbon ring
    By Green Hulk in forum 4-Tec Performance
    Replies: 12
    Last Post: 08-03-2005, 03:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •