Results 1 to 4 of 4
  1. #1

    Genesis at 5000 RPM

    Yesterday the Genesis was experiencing a little lag when going from a stop but maxed out well. After an hour it wouldn't run over 5000 RPM's (about 25 mph). No lights or warnings on the display. Pulled the spark plugs and they look great. Something must be limiting the revs at 5000. Ideas please????? May be a little more smoke but this is subjective.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Any warning displays?
    Fuely or carbed?
    If carbed, check the fuel system as in kinked hoses, dirty internal carb filters etc.

  3. #3
    Carbed. No initial evidence of cripmed lines. No warning lights or tones. Plent of oil & gas in tanks. Ridden in June with no problems. Seems odd to me that it maxes at 5000 and gets there smoothly - no spitting or sputtering which to me would indicate carb problem, gunk in lines, ... It revs smoothly, planes out and engine levels out at 5000 - multiple times.

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I'd be pulling the carbs and checking the in-line fuel filters, it could be pulling smoothly and then lay over at 5K due to lack of fuel.
    Mine was fine one day and bad the next, I cleaned the filters and the fuel restrictor and it runs like a raped ape again.
    You could hold it at the 5K RPM's for a moment, then pull the seat and see how hot the cylinders are. If they are wayyy hot, it'd seem to me it's lean and in need of a look see.
    Worth a try.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 09-26-2011, 09:17 PM
  2. gp1300 stuck at 5000 rpm
    By Binihana in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-25-2011, 06:11 AM
  3. 2001 Genesis power problem - 40 mph @ 5000 rpms
    By Number1HoustonTexansFan in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 08-04-2009, 09:48 AM
  4. Polaris Genesis won't go over 5000 rpms...
    By thedoc in forum Polaris PWC Performance
    Replies: 6
    Last Post: 06-20-2008, 09:55 AM
  5. Missing at Idle to ~5000 rpm
    By SplishSplash in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-15-2008, 07:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •