Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    mstennes's Avatar
    Join Date
    Jul 2006
    Location
    On the Columbia River above a Dam
    Posts
    843
    +1
    1

    Riva IC leak test results question

    OK I have had the dan IC on a hose under constant pressure all morning at 45# no leaks that I can see BUT there is just a little water not much on the side that goes to the TB. Could this be a leak or just condinsation? I know when the hose was loose going to the TB it would spray a little water but if you have cold water flowing through the IC and warm air from the SC you would get condinsation, right? As far as flow it appears to be flowing fine so where else could I have a plug?


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    if it was leaking, you would see it collect somewhere...

  3. #3

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    ITS LEAKING,that is what mine did.

  4. #4
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Any water inside is usually a leak..

  5. #5
    mstennes's Avatar
    Join Date
    Jul 2006
    Location
    On the Columbia River above a Dam
    Posts
    843
    +1
    1
    Quote Originally Posted by RXP Steve View Post
    Any water inside is usually a leak..
    Great just fing great, I guess I get to order a new one. Whos the fastest shipper with them in stock?

  6. #6
    I've talked to Jerry about this before and some condensation is normal.

    Here is exactly what he said...
    Quote Originally Posted by Green Hulk
    some condensation is perfectly normal. keep in mind you have 300 degree air entering the IC and 85 degree lake water circulating there as well so its going to condensate.

  7. #7
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Quote Originally Posted by mstennes View Post
    Great just fing great, I guess I get to order a new one. Whos the fastest shipper with them in stock?
    Before you go buying a new one, I would suggest trying the "Chezzy test"
    REMOVE the I/C to Throttle body tube completely, and take the ski out on the water with the seat off and run it. It will run weak and not go over 6500-7k rpms, BUT if there is a leak, you will see it pissing out the Intercooler. BEST way to test it IMO..

  8. #8
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Air pressure test the water jacket to 40psi. You should have zero leakdown over about a time period of "four-five beers."

  9. #9
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    I tested mine by filling the air side with water and putting a air hose to the water inlet blocking the exit and look for air bubbles mine had bubbles at 25# 750 for a new one from Riva intercooler only

  10. #10
    Quote Originally Posted by RXPkid View Post
    I've talked to Jerry about this before and some condensation is normal.

    Here is exactly what he said...
    I agree, I saw the same thing IN and OUTside of the IC, especially when the water temps were very cold going thru the seperate cooling system for the IC...it doesn`t always do it, I`m sure it`s bc the warmer waters have less cooling effect and the core temps must stabilize on cruising runs...PR...
    Last edited by Pale Rider; 07-16-2007 at 05:39 PM.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva ride plate test results
    By Beagleman62 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 14
    Last Post: 08-19-2007, 11:08 PM
  2. Riva IC leak test? How do I?
    By mstennes in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-15-2007, 06:27 PM
  3. RIVA ECU test results with B kit
    By Green Hulk in forum 4-Tec Performance
    Replies: 41
    Last Post: 11-23-2006, 11:29 AM
  4. Riva IC questions (need help)
    By gotpurp305 in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-11-2006, 10:27 PM
  5. Test results: Modified stock grate VS Riva grate
    By Green Hulk in forum 4-Tec Performance
    Replies: 55
    Last Post: 09-23-2005, 10:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •