Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    2002 Polaris Virage TXI

    Hi Everyone,

    I have a 2002 Virage TXI. It has 60 hours and has performed flawlessly (until now : ). We were on the lake riding around 35mph and it died. Riding along and it died suddenly.

    NOw, it will start right up, and idles. When I give it throttle, it dies pretty quickly. Maybe a couple of seconds up to 10 seconds.

    I've replaced the battery and it has fresh fuel. I can't find plugs locally, but I will order them and put them in this weekend.

    I greatly appreciate the help. I had it at a dealer for 3 weeks and they did nothing, so I just brought it home.

    Any ideas?

    Thanks!


  2. #2
    barefootpolaris's Avatar
    Join Date
    Jan 2007
    Location
    Western. NC
    Posts
    215
    You should be able to find NGK plaugs at your local auto store for that ski. Try that, but it sounds like you are having a fuel pump issue. Be careful running this ski until we figure something out, I would hate to see you burn up a piston if your system isnt running right. Someone on here should have some advise.

    BarefootPolaris

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Dirtbiker, WELCOME to the Green Hulk Forums!!

    Have you tried a TPS sensor yet?

  4. #4

    Polaris Virage TXI - Dies

    I have not replaced the TPS yet.

    Is that something that a 'reasonably capably wrench' could handle? I've done a lot of work on motorcycles and car/trucks, but not much on my Polaris.

    Thanks!

  5. #5
    Quote Originally Posted by barefootpolaris View Post
    You should be able to find NGK plaugs at your local auto store for that ski. Try that, but it sounds like you are having a fuel pump issue. Be careful running this ski until we figure something out, I would hate to see you burn up a piston if your system isnt running right. Someone on here should have some advise.

    BarefootPolaris
    I went to around 5 stores in Georgia (USA) and had no luck finding these. Which auto store do you use?

    Thanks!

  6. #6
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Quote Originally Posted by Dirtbiker2007 View Post
    I went to around 5 stores in Georgia (USA) and had no luck finding these. Which auto store do you use?

    Thanks!
    Have you tried NAPA Auto Parts?

  7. #7
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    This might be worth looking over.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	tblshoot.JPG 
Views:	182 
Size:	98.9 KB 
ID:	31848  

  8. #8
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    The TPS is easy to replace and a common problem with the injected engines. Make sure you adjust the slack out of the accelerator cable as well.
    It takes the dealers lap top to adjust the TPS as close to 100% as possible.

  9. #9
    barefootpolaris's Avatar
    Join Date
    Jan 2007
    Location
    Western. NC
    Posts
    215
    I have always been able to find them at Advance and O-reily's.

    BarefootPolaris

  10. #10
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    What's your plug number?
    Punch it into google and see if you can find them that way??

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to Remove and repair Ficht fuel pump on 2002 polaris virage txi
    By john8873 in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 07-26-2016, 11:36 AM
  2. HELP NEEDED 2002 Polaris Virage TXi MFD
    By 2boysn2skis in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-05-2011, 07:24 PM
  3. FS 2002 Polaris Virage TXi (maybe)
    By tenjuna in forum Polaris Classifieds
    Replies: 6
    Last Post: 10-29-2009, 10:51 AM
  4. 2002 Polaris Virage TXi
    By wnims in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-17-2009, 04:09 PM
  5. 2002 Polaris Virage TXi.. HELP!!! WON'T START
    By fitch615 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-05-2007, 04:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •