Results 1 to 9 of 9
  1. #1

    Red Paint Coming Off

    While polishing my red Ultra 250X with only 15 hours on it with marine polish and regular car polish noticed red paint coming off on rag.

    Has anyone experienced this problem? I brought it to my dealer's service tech's attention. Waiting for his response. This is a definitely a warranty issue. Kawi should at least pay for clear coating to stop the problem.


  2. #2
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Yes, if you search the ultra250 forum you will find many instances of it, including mine. I reported it some time ago, both on here and to my dealer.

  3. #3
    SeaDoocer
    Guest
    Ummm, don't even get me started.

  4. #4
    Silence! I Keel You! earthshaker's Avatar
    Join Date
    May 2007
    Location
    Northern CA Coast
    Posts
    1,616
    +1
    2
    Quote Originally Posted by Hydrotoys View Post
    Yes, if you search the ultra250 forum you will find many instances of it, including mine. I reported it some time ago, both on here and to my dealer.
    What did they do for you?

  5. #5
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    I havent' taken it in yet. Too busy riding all summer.

  6. #6

    Paint

    The service tech at my dealer said they checked with Kawi and confirmed that Colorrite paint job on the Ultra 250X does not have clearcoat on it and polishing it with was will show a little red haze on the rag. He said that is normal and they have not had any paint problems with Kawis.

    I also called Colorrite and they highly recommended clear coating their paint for longer lasting durability, appearance, etc. I would guess labor and materials would probably run close to $500.

    Now I must decide do I want to spend that kind of money to preserve my paint job?

  7. #7
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Typical.

  8. #8

    Join Date
    Apr 2006
    Location
    Baltimore, MD
    Posts
    71

    Wink

    If there are no problems with the paint then why did kawa send me 500$ for the painting of my boat. Every body stay with it and pressure them to make everyones boat right.....If u have a good dealership behind u it will help i did.

  9. #9

    Reply to Shermanator

    Aloha Shermanator,

    Thanks for your response. For our edification, what was the issue with your OEM paint job? Did it peel off? or just rub off?

    My red paint is coming off slightly when I apply polish. If it continues to come off to the point where it starts to show thinning and the white base primer then by all means I will pursue Kawi vigorously for compensation under warranty.

    Thanks again for your feedback.

    GHashimoto

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bottom Paint - What needs to come off or out?
    By Gruntus in forum Kawasaki How To & FAQs
    Replies: 5
    Last Post: 07-12-2012, 01:49 AM
  2. Nose cone keeps coming off...
    By Pale Rider in forum 4-Tec Performance
    Replies: 15
    Last Post: 08-01-2006, 07:18 PM
  3. Nose Cone comes off:
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-23-2006, 04:28 PM
  4. Viper Red Paint Code
    By jasonj2004 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-04-2006, 06:34 PM
  5. Nose cone coming off.
    By Mark S in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-20-2005, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •