Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    H2HO's Avatar
    Join Date
    Apr 2007
    Location
    Tampa Bay
    Posts
    4,063
    +1
    11

    Water in Hull (RXP)

    I am fairly new to boating and was wondering how much is too much water in a hull. A few months ago I never noticed water in my hull at all. Everytime after I am out of the water I wash down the engine, flush, and wash exterior. I always lift my trailer and rest it on the tailgate of my truck so its always on an incline during this whole process.
    Lately I have been seeing some water in the bottom of the hull. Last night I syphoned 2 gallons, from the space in the front compartment right infront of the gas tank. Is this normal?
    The weird thing is that I thought it looked like there was no water in the hull after washing it on Sunday?!
    Any suggestions? Is something leaking?


  2. #2
    .... RXPwildchild's Avatar
    Join Date
    Jun 2007
    Location
    Wake Forest, NC
    Posts
    239
    +1
    1
    Open your front storage compartment (the big one) and check the black sealing boot at the front hinge of it. My 07 would stay bone dry when riding, but when I washed it, I'd get quite a bit of water in the nose of the ski. Found this boot to be improperly seated.
    Last edited by RXPwildchild; 07-17-2007 at 08:20 AM. Reason: typo

  3. #3
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    i had a leak in the hose running from the pump to the intercooler. it runs under the engine so it was a bit challenging to find at first. you might want to check that also. it runs from the pump, up under the exhaust manifold and to the intercooler.

    and yes, two gallons is an indication of something wrong.

  4. #4
    H2HO's Avatar
    Join Date
    Apr 2007
    Location
    Tampa Bay
    Posts
    4,063
    +1
    11
    Quote Originally Posted by RXPwildchild View Post
    Open your front storage compartment (the big one) and check the black sealing boot at the front hinge of it. My 07 would stay bone dry when riding, but when I washed it, I'd get quite a bit of water in the nose of the ski. Found this boot to be improperly seated.
    Ok just checked it. Boot is good.

  5. #5
    H2HO's Avatar
    Join Date
    Apr 2007
    Location
    Tampa Bay
    Posts
    4,063
    +1
    11
    Quote Originally Posted by SeanCucf View Post
    i had a leak in the hose running from the pump to the intercooler. it runs under the engine so it was a bit challenging to find at first. you might want to check that also. it runs from the pump, up under the exhaust manifold and to the intercooler.

    and yes, two gallons is an indication of something wrong.
    Under the engine! Chit...this is going to be fun. If I verify this is the problem, can I still use the ski until I take it to the stealer for warranty?

  6. #6
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    Quote Originally Posted by sstaino View Post
    Under the engine! Chit...this is going to be fun. If I verify this is the problem, can I still use the ski until I take it to the stealer for warranty?
    much easier to check than you think...here's a couple pictures of which one I had a problem with. I was able to reach down and pull it aftward a few inches and expose the hole. Then, just took it to the auto parts store and got a heater hose of the same length and diameter. The hose is marked by a red band.




    Hope this helps or you find you're leak soon!

    Sean

  7. #7
    H2HO's Avatar
    Join Date
    Apr 2007
    Location
    Tampa Bay
    Posts
    4,063
    +1
    11
    Wow! That is a very detailed instruction. You should make manuals for BRP!
    thanks!!!!! I will check it out!

  8. #8
    H2HO's Avatar
    Join Date
    Apr 2007
    Location
    Tampa Bay
    Posts
    4,063
    +1
    11
    Quote Originally Posted by SeanCucf View Post
    much easier to check than you think...here's a couple pictures of which one I had a problem with. I was able to reach down and pull it aftward a few inches and expose the hole. Then, just took it to the auto parts store and got a heater hose of the same length and diameter. The hose is marked by a red band.




    Hope this helps or you find you're leak soon!

    Sean
    Ok, couldnt find a leak in this hose or any other area for that matter. Last weekend during my wash and flush, I removed the rear plug assembly (8mm hex heads) and the water in the hull came gushing out. The ski hull has been bone dry since Saturday. Tomorrow when I put it in the water, I will check for leaks again. Do you think it was just the water when I hose down the engine? Why wouldnt it all come out of the plugs. Do you think it doesnt syphon water out of the hull anymore??

  9. #9
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    Check your bailer hoses, Someone else with an 07 said he had a hole in one of his hoses that was filling his hull up. Also go over all the exhaust hose clamps or pretty much any clamps on hoses that you know carry water such as intercooler to exhaust manifold, j-pipe to manifold and so on.........

  10. #10
    H2HO's Avatar
    Join Date
    Apr 2007
    Location
    Tampa Bay
    Posts
    4,063
    +1
    11
    Quote Originally Posted by ReDevilRXP View Post
    Check your bailer hoses, Someone else with an 07 said he had a hole in one of his hoses that was filling his hull up. Also go over all the exhaust hose clamps or pretty much any clamps on hoses that you know carry water such as intercooler to exhaust manifold, j-pipe to manifold and so on.........
    The bailer hoses are the ones that connect back to the drain plug correct?
    I will check all clamps. Thanks!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 rxp water in hull issue
    By missrxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-06-2012, 10:45 PM
  2. 04 rxp water in hull (bailer questions)
    By Jessie00721 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-30-2012, 05:04 PM
  3. 05 rxp geting water in hull
    By RXP2 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-08-2010, 08:16 PM
  4. Rxp cavitating badly, water in hull
    By kenshin89 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-21-2006, 12:13 AM
  5. RXP Water in Hull
    By jpwt62 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-06-2005, 10:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •