Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843

    04 Rxp Taking On Water

    I cant figure out where Im getting the water from , I have double and tripled checked all the obviousand replaces the carbon seal However It is still taking a LOT of water on even as it just sits there , any suggestions???


  2. #2
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Put it in the water and take the seat off, run it and look for leaks.

  3. #3
    rior1's Avatar
    Join Date
    Feb 2007
    Location
    uk ESSEX
    Posts
    356
    have you removed opas,thru hull exhaust?
    mate had these and he was taking on water turned out the nuts were loose and he hadnt sealed them up

  4. #4
    Try putting water in the ski and see where it's finding its way back out.

  5. #5

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592
    IM HAVING THE SAME PROBLEM and been having it for some time now. ive tried everything, i am getting some from the right bailer, so im gonna lengthen the hose and loop it a few times. but i dont think that will fill it as fast as it is taking it in. time for an 08

  6. #6
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    What i did for my buddies ski is on land on the trailer start filling the hull with water and look for leaks....

  7. #7
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    not trying to be a smart ass but i did all of the above . i checked my opas block offs , checked my rear hull thru , filled it with water and checkd for leaks .. NOTHING!!!! It fills up pretty fast too..

  8. #8

    GPS

    I WOULD CHECK YOUR GPS I WOULD SAY IT IS BROKE!!!!!

  9. #9

    SERIOUSLY

    Have you ran it on the hose on the trailer to see if you have any leaks that way

  10. #10
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    Quote Originally Posted by CRAZEDRXP View Post
    not trying to be a smart ass but i did all of the above . i checked my opas block offs , checked my rear hull thru , filled it with water and checkd for leaks .. NOTHING!!!! It fills up pretty fast too..

    Can you hear it dripping or anything? Did you have any hi-temps? More info!!!! Any acceleration problems? Anything to do with the carbon ring will kill performance, as if you got seaweed or grass in the intake.

    Water line from i/c to bottom of exhaust manifold still on?

    Brendan

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP taking on water, need help...
    By JetmechF16 in forum Sea Doo Open Discussion
    Replies: 32
    Last Post: 10-21-2009, 03:38 PM
  2. rxp taking on water
    By laith11 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 09-02-2008, 08:20 PM
  3. 04 RXP taking on water, can blower be culprit?
    By JCHOUCK in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-14-2006, 10:20 AM
  4. does the rxp take on water easily??
    By CarFanatic in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-30-2006, 08:09 AM
  5. RXP-Taking on water
    By RXPDAVID in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-10-2005, 06:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •