Results 1 to 3 of 3
  1. #1

    Polaris MSX110 2004 "Multiple Problems"!

    Polaris MSX 110 2004, 1st, when you start it the check engine sign comes on, then after a couple of seconds it goes off. 2nd, when you run the ski at full throttle the turbo when it reaches its max (full bars) it starts to oscillate, I notice the rpmís going from 6800-7400, the other ski (MX110) top rpm is 7100. If you run the ski and keep it from full turbo it doesnít do it. 3rd, when you run the ski and hit a wave it just shuts off, if you hit the gas from a dead stop it revs up (4500rpm avg) and just shuts off and if you put the ski under load like towing another boat it will just shut off. Sometimes after it shuts off it doesnít want to start then it just does. Iíve already had it in the shop twice this year for these reasons. Iím at a total of about 1,200.00 to fix these problems that still exist! New battery, loose ground, new wiring harness, exÖ


  2. #2

    Join Date
    Oct 2006
    Location
    Beaver Falls, PA
    Posts
    281
    "Polaris MSX 110 2004, 1st, when you start it the check engine sign comes on, then after a couple of seconds it goes off."
    This is normal it is a self check for the computer should happen for aprox 15 seconds.
    "2nd, when you run the ski at full throttle the turbo when it reaches its max (full bars) it starts to oscillate, I notice the rpm’s going from 6800-7400, the other ski (MX110) top rpm is 7100. If you run the ski and keep it from full turbo it doesn’t do it."
    These units are meant to run on 91+ octane makes usre you have new fresh gas. They do have a knock sensor that will retard the timing about 500 rpms with cheap pump gas. It sounds more like a bad O2 sensor the dealer should have looked at the milli volts and it should have been 450-800. Not 0-200.
    "3rd, when you run the ski and hit a wave it just shuts off, if you hit the gas from a dead stop it revs up (4500rpm avg) and just shuts off and if you put the ski under load like towing another boat it will just shut off. Sometimes after it shuts off it doesn’t want to start then it just does."
    PPU interface with bad connection or is failing. Could have slight corrosion on the connections. Clean and retest unit or take this to a dealer and have them check it.

  3. #3

    Thanks

    Thanks for the info, I will let you know the results!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 05-16-2012, 03:15 PM
  2. FS 2004 Polaris MSX110 Hood / Compartment Door
    By grumpy_steven in forum Polaris Classifieds
    Replies: 0
    Last Post: 07-04-2011, 08:23 AM
  3. FS 2004 Polaris MSX110 Mirrors
    By grumpy_steven in forum Polaris Classifieds
    Replies: 0
    Last Post: 07-03-2011, 09:52 PM
  4. FS 2004 Polaris MSX110 Seat
    By grumpy_steven in forum Polaris Classifieds
    Replies: 0
    Last Post: 07-03-2011, 09:24 PM
  5. FS 2004 Polaris MSX110 & Trailer - $1200
    By seatsR4toilets in forum Polaris Skis
    Replies: 12
    Last Post: 07-27-2010, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •