Results 1 to 7 of 7
  1. #1

    Smile slipping or cavitating

    i have a 2000 yam.1200xl that feel like a cluth slipping when you give it throttle. have installed new impeller and housing still same problem.


  2. #2
    My son (mohawk man) jeffsntx's Avatar
    Join Date
    Sep 2006
    Location
    Belton TX
    Posts
    2,598
    +1
    1
    You need to buy a pump plug kit, and seal the shoe real good and that should help it tremendously.

  3. #3
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Quote Originally Posted by jeffsntx View Post
    You need to buy a pump plug kit, and seal the shoe real good and that should help it tremendously.

    +1

  4. #4
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8
    felt could be missing also

  5. #5
    African-American
    Join Date
    Feb 2007
    Location
    Cape Town, South Africa
    Posts
    2,226
    +1
    88
    that black strip make a difference ? cant i use rubber selaer instead ?

  6. #6
    what exactly is a pump plug kit, what is it used for and where do u get them?

  7. #7
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    They are rubberized pieces that fill the voids in the pump shoe (where the intake grate bolts to).

    The air coming through there is mixing with the water and causes your hesitation (cavitation) at start. Once you install it you will notice a diff in the acceleration.

    Once that is complete if you still arent happy with the acceleration you could always look at a JetWorks kit and impeller.

    Since you have the intake grate out - for safety sake find a R&D or Riva intake grate and replace the OEM one - it will help the ski in rough water and stop its tendency to roll forward when you lay off the gas. It will also stop it from making violent turns when you arent expecting it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gp1200 driveshaft slipping, or cavitation?
    By jimballs in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-03-2013, 08:15 PM
  2. Supercharger slipping? Or bad spark plugs?
    By RXPteamtimebomb in forum 4-Tec Performance
    Replies: 33
    Last Post: 06-02-2012, 09:06 PM
  3. RXTX 255 Pump slip or cav
    By fussy1 in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-08-2010, 07:30 PM
  4. What are the symptoms of an overly worn wear ring? (Or cavitation?)
    By bgaidan in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-31-2010, 10:13 PM
  5. SC slipping or bearing?
    By Landscraper in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-20-2009, 07:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •