Results 1 to 10 of 10
  1. #1
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536

    Do you think this scrubbed speed?

    The importance of proper engine alignment. (And the carbon ring went right after!)


    Brendan
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	0718072036.jpg 
Views:	63 
Size:	73.7 KB 
ID:	32070   Click image for larger version. 

Name:	0718072032.jpg 
Views:	46 
Size:	81.9 KB 
ID:	32071  


  2. #2
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    Did that do any other damage? Hopefully you didn't sink, or weren't alone?

    I'd rather have that then what I'm looking at right now.

  3. #3
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    Quote Originally Posted by _Lurker_ View Post
    Did that do any other damage? Hopefully you didn't sink, or weren't alone?

    I'd rather have that then what I'm looking at right now.

    After MB III when I blew a c-clip, I installed a bilge, so there was no sinking involved. Drivetrain was getting louder/rougher the last few rides....I should have seen it coming!

    What do you have going on?


    Brendan

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    OUCH!

  5. #5
    Website may not be suitable for small children WOT's Avatar
    Join Date
    Mar 2007
    Location
    DFW
    Posts
    654
    I heard alot of people are running the 2-peice shaft, but I think they meant something different than this...

  6. #6
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    2 piece? Try like 20 piece! We had to use a magnet to go fishing in the shaft housing!

  7. #7
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    Quote Originally Posted by BDNJ View Post
    After MB III when I blew a c-clip, I installed a bilge, so there was no sinking involved. Drivetrain was getting louder/rougher the last few rides....I should have seen it coming!

    What do you have going on?


    Brendan
    What kind of bilge did you install? I didn't think anything short of a commercial pump could move the kind of water a failed carbon ring would allow in.

    my problems...http://greenhulk.net/forums/showthread.php?t=31822

  8. #8
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    Quote Originally Posted by _Lurker_ View Post
    What kind of bilge did you install? I didn't think anything short of a commercial pump could move the kind of water a failed carbon ring would allow in.

    my problems...http://greenhulk.net/forums/showthread.php?t=31822

    Luckily, the ring didn't totally disintegrate. It didn't completely give way like normal. I was under tow pretty quickly with in-line pinched off. It was cracked though and ultimately fell apart in my hands once removed. Atwood 500gph is all I've got.




    Oh yes, now I remember. What a mess you do have. Best of luck with your journey back.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	0703071850.jpg 
Views:	53 
Size:	73.5 KB 
ID:	32085  
    Last edited by BDNJ; 07-19-2007 at 12:25 PM.

  9. #9
    Website may not be suitable for small children WOT's Avatar
    Join Date
    Mar 2007
    Location
    DFW
    Posts
    654
    Is this on the same ski that almost sunk at the Mudbug?

  10. #10
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    Quote Originally Posted by WOT View Post
    Is this on the same ski that almost sunk at the Mudbug?

    Yup! Poor fella..it's been through a lot. And 81+ when the shaft finally went!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Do you think this video a little bit biased?
    By arubanfzr in forum Yamaha PWC Performance (4-stroke)
    Replies: 18
    Last Post: 09-06-2010, 11:38 PM
  2. do you think this prop is repairable??
    By lightning666 in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-19-2010, 05:39 PM
  3. What do you think this is worth
    By Mike's GPR in forum Yamaha 2 Stroke Skis
    Replies: 6
    Last Post: 11-05-2008, 09:50 AM
  4. Do you think this is a legit sale?
    By rx4pain in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-27-2008, 06:38 PM
  5. Do you think this might be hindering performance?
    By Dazza169 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 02-28-2008, 05:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •