Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    May 2005
    Location
    Elk Grove, CA
    Posts
    20

    I am unhappy!!!!!!

    Well, yesterday I had the dealership put in the Solas 14/19 A couple hours later, I took it to the same lake I have been going to and to my surprise, my RXP is slower. I can literally feel it. My dream-o-meter was only showing 68 and 7700-7750rpm. I thought I was going to loose maybe 100 rpm due to the more aggressive impeller but ??????. Also the ski doesn't seem to accelerate as hard from 60 and up like it use to. I have the R&D air intake, R&D grate and also did the waterbox mod and resonator eliminated. Before the impeller mod it use to accelerate fast at any given speed(below 70 of course). The impeller was the only mod that was done yesterday. The wear ring is in great condition. I am going to put the stock impeller and see if it perform as it use to. I had to waste my gas just to get it down to 3 bars and it's still pretty much the same. Any input on this Hulk or anyone else????


  2. #2
    Therock's Avatar
    Join Date
    Apr 2005
    Location
    Jacksonville,FL
    Posts
    170
    Be interested to see what happens when you put the stock prop back on.

  3. #3
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    R&D intake is worst then the stock intake .. there are dyno tests and real worl tests that have prooved this many many mos ago .. look where your filter is sitting!!! it is ove the hottest spot of the motor sucking in nothing but HOt air ... I got suckered into buying an r&d i had no idea about it until I got it .. I knew rite away it was a bad design but i installed it anyway just for the hell of it .. it was no faster and i lost almost 1000 rpms after heat fade ... that is your first problem that intake is JUNK , put it in the trash where it belongs and get a riva or ppg ... second have the prop repitched and finished by someone that knows what they are doing like IMPROS ....

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,898
    Put the stock impeller back on and send the Solas to PPG for a repitch. Some of the Solas 14/19 are notorious for being out of whack right out of the box.

  5. #5

    Join Date
    May 2005
    Location
    Elk Grove, CA
    Posts
    20
    Yeah I agree about the intake where it sits at. I thought it was going to be where the stock air filter at but to my surprise when I read the instruction. I told the guy at my dealership that I thought it was a stupid design. Hot air coming from the engine goes straight to the intake. Anyways, I had to take the pump off tonight and I found out the shaft spline seal(the anodized green piece) came off the impeller. Basically when I pulled the pump off, that piece was still on the shaft. Now I am wondering if that was causing the problem. I'm going to bring the pump to the dealership and show/tell the owner what I found out. I'm thinking of borrowing the impeller tool so I can keep the solas in there and swap in the stock impeller on sunday night for monday run.

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,980
    +1
    1,898
    that definately had something to do with your poor performance.
    i have NEVER been able to keep the green nose cone on my Solas impellers. I always reuse the stock rubber nose cone. I apply a little silicone to the threads and then tighten it snugly on the impeller and i havent had a problem yet.

  7. #7
    Hulk- You might want to put the Solas nose cone as a "sticky". I used red locktite, also the alignment issue.

  8. #8

    Join Date
    May 2005
    Location
    Elk Grove, CA
    Posts
    20
    I put my stock impeller back on. Will go out tomorrow to find out what happens. If it goes back up to the original performance, I don't know if I'm still going to keep the Solas. I can't beleived i just wasted $350. Who sells the prop tool? Mine did not come with it.

  9. #9
    A prop tool does not come with it. It is extra. You can get it at many places such as ppg, riva or any dealer should be able to order it. You can use either the solas made prop tool or the oem sea doo one. Like hulk said, your prop needs to be repitched. Give PPG a call and they will repitch it for you. They will ask you for specific information such as you gave in this post. Once you have the prop repitched for your specific ski you will love the increased acceleration and top speed. Oh and you might want to consider getting the riva intake grate instead of the r&d. It has proven to be the better grate for lake conditions. Good Luck!

  10. #10

    Join Date
    Apr 2005
    Location
    Augusta GA
    Posts
    720
    Bennie,
    Dito to what Chris said, the R&D air intake is not a good product. And if you got a Soals impeller out of the box it need some attention. PPg repitched my impeller and Glen his the sweet spot dead on the head. I am running the Riva air intake and after some hard riding all day, I mean doing some wave jumping and a hell of alot of 360's with water coming over the front of the ski I ahve had now problems (Knock on wood) A trick that I used to keep the green cone on my Solas impeller is, I took a wire while and put it on my drill and got off the green paint off the threads. Then I put some blue loc-tite on the threads and backed it back on the impeller. You can alos use some type of TRV on the stock nose cone

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WAY UNHAPPY with RIVA!!!
    By phumb in forum Sea Doo Open Discussion
    Replies: 29
    Last Post: 07-07-2011, 12:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •