Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    Join Date
    Jul 2007
    Location
    orlando
    Posts
    176

    Thumbs down new to polaris need help please

    well here is the story i have a 94 polaris sl 650 and i lost my compression so i tore the top end down and i saw that the pistons were bad and the cylinders were scared....so i honed the cylinders and bought some wiseco pistons and tore the oil pump out and put a block off kit in so now i went to premix.....and i also got a tripple fuel pump for it....now for the prolbem i went to start it out of water and it took a wile to start because of the fuel pump because no fuel in the lines and when it started i didnt have the trigger hooked up so i was holding the cable and it was smoking alot and then my fingers slipped and it shut offf and would start back up.....i also took apart the water seperator along time ago and the o ring might not of seated could that be why it would start back up cause of fuel pressure loss.......thanks


    syd


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    pepp Welcome to the hulk.

    It still should start try dribbling a little premix down the carbs. Do a compression check. Check for spark. Report any findings.

  3. #3

    Join Date
    Jul 2007
    Location
    orlando
    Posts
    176
    hey i check the compression and its good and the plugs are brand new and there firing....

  4. #4

    Join Date
    Jul 2007
    Location
    orlando
    Posts
    176
    ok i got it started again and i noticed that the lines that are blocked off it was to much pressure and it was squirting all over.....this is the set up i have on the polaris for the fuel pump....http://www.sbtontheweb.com/forum/att...tachmentid=269

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    You need to install some good fuel grade caps.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	TripleFuelPumpRouting.jpg 
Views:	53 
Size:	585.0 KB 
ID:	32343   Click image for larger version. 

Name:	triplefuellines.JPG 
Views:	44 
Size:	175.3 KB 
ID:	32344  
    Attached Files Attached Files

  6. #6

    Join Date
    Jul 2007
    Location
    orlando
    Posts
    176
    hey...ok i do have that set up but i dont have to same plugs i have some crappy rubber plugs....and also i dont have a restrictor and is that important and where can i find one....thanks

  7. #7
    a restrictor is very important. it will prevent you from holeing a piston at WOT Do a search on the board as to how to make one.

    I'm in the process of making one myself

  8. #8

    Join Date
    Jul 2007
    Location
    orlando
    Posts
    176
    ok so my ski wont start now i found the restrictor and it is a little brass fitting with a verry small hole and threads at the other end how do i got about installing...i never got instructions with the kit......thanks so much
    Last edited by pepp101; 07-22-2007 at 12:30 PM.

  9. #9

    Join Date
    Jul 2007
    Location
    orlando
    Posts
    176
    ok so i was just out after i put the restrictor in and it sounded like it wanted to start i saw a flame in the intake twice......thanks

  10. #10

    Join Date
    Jul 2007
    Location
    orlando
    Posts
    176
    ok i have one more thing to add i have a oil level sensor and i havent ziptied it up to where it thinks it have oil would that matter if the engine will start or not.....thanks

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to PWC need help
    By Onthego in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-16-2010, 08:57 PM
  2. New to skis. Need help
    By Arkavian in forum Polaris Open Discussion
    Replies: 20
    Last Post: 04-06-2010, 10:15 PM
  3. New to skis need help.
    By CalledFollower in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-26-2008, 11:08 PM
  4. New to Forum-Need help with 07 GTX
    By Live Fast in forum 4-Tec Performance
    Replies: 1
    Last Post: 10-17-2007, 06:39 PM
  5. New to forum...tech help....please
    By paramuir in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-07-2007, 12:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •