Results 1 to 3 of 3
  1. #1

    Join Date
    Jun 2006

    ? What caused this damage

    I installed my v3's yesterday and went out to test. Motor ran for about 2 min and died on me. got it back to the dock and presure tested it this is what I found. Did somthing get in there. I used the one piece gaskets from the vf3 install tip's instructions. I did not presure test.
    Last edited by thrasher63; 07-21-2007 at 02:26 PM.

  2. #2
    What did you find?

  3. #3
    Duke's Avatar
    Join Date
    Jul 2006
    Quote Originally Posted by porksword View Post
    What did you find?
    What Pork said.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what caused this damage to the piston???
    By shopofwax in forum 2-Stroke Performance
    Replies: 6
    Last Post: 09-07-2012, 12:12 AM
  2. What caused this engine damage
    By iamadam1122 in forum 2-Stroke Performance
    Replies: 27
    Last Post: 07-25-2012, 08:56 PM
  3. Piston Damage Ideas on what caused this? *Pics*
    By ktyamaha36 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 7
    Last Post: 09-10-2010, 10:19 PM
  4. 99 GSX LTD What caused this damage
    By steelroe in forum 2-Stroke Performance
    Replies: 10
    Last Post: 07-19-2010, 08:36 AM
  5. What caused this Piston Damage - Ultra 150
    By hotshotbz in forum Kawasaki PWC Performance (2-stroke)
    Replies: 14
    Last Post: 01-27-2010, 04:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts