Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: 95 slt 750 help

  1. #1

    95 slt 750 help

    Hope someone can help, My bike will start and run fine out of water but in water and under a load it will not take off, I can play with the choke and it'l go but just as soon as you let off the gas it's the same thing, Once i get it going it will run fine on midway and top end. Can someone please tell me where to start.

    Thanks
    Roger


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Do you mean it only turns about 4,000 RPM's?
    Do the engine RPM's raise high but the boat just not move?
    A littlemore infor would be great.

    Welcome to the the Green Hulk Forums!!!

  3. #3
    No the engine will no come up to speed, when i play with the choke a little it will come up to speed and run fine.
    I had just replaced the drive coupling, put it in the water and it ran great for a few min. and then it's like the motor dont wount to run, so i put it on the lift and it runs fine, put it back in the water and no power again, Its like the when you put a lode on it, it dosent wount to nun but after geting the rpm up it runs great. thanks for trying to help

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    When you hold it at the RPM's when it doesn't rev up, how many RPM's is it?? In other words what are your max RPM's while you're in the water.

  5. #5
    After I get it going and paned out about 6000 or so.
    to me it kind of make me think fuel system.

  6. #6
    Bing-A-Ding-Ding-Ding, Brrrrrap! Brrrrrrrrrap!!! Polaris_Nut#1's Avatar
    Join Date
    Aug 2006
    Location
    Pittsfield, MA
    Posts
    3,350
    +1
    26
    Check the compression. Have the carbs ever been cleaned? Do you have any kinked fuel lines? (like where they go into the tank)

  7. #7
    Changed both fuel filters, drained and cleaned fuel tank, replaced spark plugs. It runs a little better but still the same thing.

  8. #8
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    If it were my boat with the known fue lissues and up-dates, the age of the boat I'd be changing ALL of the fuel lines, replaceing the fuel pump, cleaning the carbs and changing the fuel valve.
    My pennies worth.

  9. #9
    OK Took the boat back out this weekend and same thing but when i'm gasing it and the rpm's are not comeing up if i hit a wake and the back of the boat comes out of the water the rpm's come up and it will take off.
    I replace the drive coupling just before this happend could there be something i a bind, because when there is not load on the inpeler the engine runs fine.

  10. #10
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    How are the Jet pump bearings?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 slt 750 no fuel (Need Help )
    By Firemen358 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-19-2016, 10:01 PM
  2. Can someone make sense of this fuel routing? HELP! (95 SLT 750)
    By jwalts37 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 06-02-2015, 03:37 PM
  3. 95 SLT 750: Weak Spark...Need Urgent Help!
    By ShiftRacing in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-20-2012, 08:36 AM
  4. 95 slt 750 service manual help
    By justinjohnsonh20 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-02-2012, 08:29 AM
  5. 95 slt 750 please help
    By nick34 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 10-05-2009, 05:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •