Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25

Thread: Any Ideas????

  1. #1
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843

    Any Ideas????

    STill only going 70.0 here is a list of my mods

    1 x Riva RXP Intake Grate (RS22050) = $129.95
    1 x RIVA Rear Air Intake for RXP (RS13056) = $399.95
    1 x RIVA Rear Exhaust Kit (RS15050-1) = $249.95
    1 x Power Cooler, w/Pro-Series BOV for Stage III (RS1750-PC-001) =
    $1,599.95
    1 x RIVA Pro-Series SD Supercharger Housing and Impeller (RS1750-2M011) =
    $799.95
    1 x 42 # Fuel Injectors (set of 3) (42# Injectors) = $200.00
    1 x SRX-CD-15/20R (SRX-CD-15/20R) = $249.95
    1 x OPAS Removal Kit, RXP / RXT / GTX (RS29050-1) = $99.95
    1 x Stainless Steel Replacement Wear Ring for 215 HP Units (RS33-159-SRX) =
    $189.95


  2. #2
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    By the way i tried two differnt GPS ... MY RPMS are a CONSISTENT 8100 ... the acceleration is SICK but stops pulling up top as soon as it hits 70

  3. #3

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    DANG CRAZED WITH ALL THOSE MODS AND ONLY GOING 70,MAYBE YOU SHOULD TRY TO MAKE A RUN WITHOUT THE TRAILER HOOKED TO THE BOTTOM OF THE SKI. INTAKE GRATE HANGING DOWN,BOOST LEAK.TODD

  4. #4
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    NO And NO .. Im turning 8100 !!! If I had a boost leak I would not be seeing 8100 on a consistent basis....

  5. #5
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,064
    +1
    790
    Crazed, I am shocked also. My 06 I sold to rapid fire. Only had a home made 4in rear air, RR high boost SCer impeller and a Solas 14-19R and it runs 73+.

    It has to be in the hull, since you are seeing 8100rpm's.


    Full tank of gas?
    Ridder wieght?


    .

  6. #6
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    1/2 tank of gas .... Im 200 lbs

  7. #7
    Rideplate angle maybe??? Maybe the rear of it is shimmed down too much? Probably not but I'll throw that out there anyways.

    *EDIT: I also think it would be a good idea to get a solid front motor mount while running that SS ring just for more insurance, unless you just forgot to list it.

  8. #8
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    ttt

  9. #9
    75 mph on a budget TorquePhoto's Avatar
    Join Date
    Jul 2006
    Location
    Lake St. Clair, MI
    Posts
    360
    somthing is def not right.... I have run 75.4 with the same mods as you MINUS the supercharger upgrade. see full mods in my sig. Check your pump shoe.....I lost 4-5 mph when mine cracked

  10. #10
    Clayton, do you have any pics of that cracked shoe that you could send me?

    Thanks.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trailer Problem - Any Ideas?
    By Jarrett in forum Sea Doo Open Discussion
    Replies: 27
    Last Post: 05-22-2013, 03:31 PM
  2. Any Ideas?
    By kenshin89 in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-25-2006, 07:57 PM
  3. New RR IC still not helping, any ideas ????
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 30
    Last Post: 08-24-2005, 09:41 PM
  4. Was not impressed with new IC any ideas??
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-10-2005, 11:15 AM
  5. Any ideas for a club name??
    By SuzanGPR in forum Sea Doo Open Discussion
    Replies: 21
    Last Post: 05-14-2005, 08:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •