Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38
  1. #1

    Got the ski back together and here's the story...still some ???'s.

    Ok, so I got my pump bearing issue straightened out and got the whole ski back together yesterday. I went out and did the IC leak test with the IC in the ski and the pipe from the TB to the IC removed and no leaks showed up. I resealed all the pipes with windex and used a good amount of silicone on the IC blockoff. Went out today and I am now topping out at and maintaining 72.8mph and 7900~7950 RPM. My boost gauge is not working at all, so I think I may need to redo the setup for it or try a better gauge. The ski does feel much snappier out of the hole but not as much as I expected. I think I may be pitched too steep now, but at least it leaves room for a rear intake, don't you guys think?

    Here's the numbers:

    Elevation...1,150 ft.
    Temp....73*F
    Humidity...63%
    Lake temp...69*F
    RPM...7900~7950
    Speed...72.8mph @ two notches above neutral
    Boost...no clue
    Mods...XS IC, Vortech SC, 2* wedge, 15/20R prop, Riva 3" SC intake, Jerry's '04 metal clutch washers, Riva rear exhaust, Riva intake grate, Riva pro series OPAS blocks, rideplate and intake grate holes filled in.
    Notes...my SC only has 3 hours of ride time on it (easy 3 hours, no hardcore riding) since Jerry has worked on it.
    Questions...Anyone know where I may be able to find another 2mph with my setup? I figure the prop is too steep, but anything else?

    Also wanted to thank everyone for their help and concern in my other problem thread.
    Last edited by RXP-REX; 07-24-2007 at 09:25 AM.


  2. #2

    7900

    If you get that extra 200 rpm you will be right at 75!!!!!

  3. #3
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Yea, you're too tall, need to tweek that prop and get to 8100, you'll find another mph there....You should be pulling high 73's to low 74's...I would suggest dropping that nozzle to about 1 notch above neutral....AND check to make sure neutral IS neutral...

  4. #4

    rear air

    you are on the right track with the rear air......i gained rpm with mine!

    remember dont tweek the prop until you are done with your mods..........

  5. #5
    Quote Originally Posted by DIGGS View Post
    If you get that extra 200 rpm you will be right at 75!!!!!
    Yeah, that's what I figured. Im thinking about swtiching to a rear intake to gain some RPM though instead of repitching. Would this be ok? I'm sure Jerry and Riva would rather have me get a rear intake instad.

    Quote Originally Posted by Danny View Post
    Yea, you're too tall, need to tweek that prop and get to 8100, you'll find another mph there....You should be pulling high 73's to low 74's...I would suggest dropping that nozzle to about 1 notch above neutral....AND check to make sure neutral IS neutral...
    Yeah, I definately agree on being too tall, I can feel it. She's pulls good until 7600 RPM then creeps to 7900~7950. Thanks Danny!

  6. #6
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Yea, the larger air will help....If you don't go Riva, look into the standard 4" Kanaflex style setup. If done right, you can do it for less than $100, and that will be your 200 rpm right there....

  7. #7
    [quote=RXPkid;353527]Yeah, that's what I figured. Im thinking about swtiching to a rear intake to gain some RPM though instead of repitching. Would this be ok? I'm sure Jerry and Riva would rather have me get a rear intake instad.


    i have a homemade rear intake with 4 holes in the grab bar!!!!

    as long as your not a surf rider the rear intake is ok.

    you might want to consider getting rid of that stg2 imp and getting the greenwheel or s3.

  8. #8
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Kid, what was wrong with your pump? Bearings out, or?

    Your situation is a puzzle ... I had a virtually identical setup when I put on my Riva Stg 2, only difference was the Riva IC and I had pulled 2mm back from my trailing edge, and was running an 81.5mm nozzle. But with a stock SC (with metal washers), I ran 75.5 at 7950 rpms ...

    I think I would pull 2 mm out of your 15/20, get an adjustable nozzle and try 81 or 81.5mm. Also try a run with the seat off, see if rpms or speed go up.

  9. #9
    Just got back in again...

    New numbers:

    Elevation...1,150 ft.
    Temp....73*F
    Humidity...63%
    Lake temp...69*F
    RPM...7900 solid. No surging, they stayed pinned.
    Speeds...72.9 (2 notches above neutral), 73.0 (1 notch above neutral), 73.3(1 notch above neutral), 73.3(1 notch above neutral), (1 notch above neutral), 73.4(1 notch above neutral), 73.1(1 notch above neutral)
    Boost...no clue
    Notes...Did some holeshots this time and she's pulling hard!

    So I'm definately down 200 RPM and I figure I need to be 2mph faster also. So I think I would rather add a rear intake to gain the RPM before I jump into repitching. Vern you seem to disagree. Could you shine some more light for me? Any other ideas? What size is the stock venturi again?

    Oh, almost forgot to mention that Danny is a smart mofo. The trim suggestion worked. She's currently a solid 73mph ski @ 7900RPM.

  10. #10
    Quote Originally Posted by Vern View Post
    Kid, what was wrong with your pump? Bearings out, or?
    Water got in the fucking thing and I had to wait a month to get parts for it to be rebuilt. It's good now though!

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 10-21-2012, 10:02 AM
  2. Got my GPR back together and found bad news
    By spraydrice in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 06-01-2009, 03:53 PM
  3. Finally got my ski back!... :(
    By GeoRXT in forum Sea Doo Open Discussion
    Replies: 28
    Last Post: 07-15-2008, 09:08 PM
  4. got my ski back from the dealer
    By gba in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-13-2008, 10:11 PM
  5. I got my ski back.
    By muskadoo in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-13-2005, 07:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •