Results 1 to 6 of 6

Thread: 03 msx 140

  1. #1

    03 msx 140

    Hey guys

    new to the site and just wanting to bounce a few questions off of you guys. first off i just purchased a 03 msx 140 and genesis I was wondering how everyone like the direct injected 1200. both of the skis sat for a while and the genesis is running great but the msx starts and idles fine and for the most part runs good but every now and then it starts missing and bogging down and with a quick let off and back on the throtle if goes away. seems fine when first fired up seems to act up when engine is warmed up.

    any help would be great thanks


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Jay, I had a similar issue with my 03 and it wound up being loose stator screws.
    I'd start with a TPS and see if this corrects your problem, the injected engines seem to have issues with the TPS.
    Next I'd check fuel pressure and see if it drops off when you have your running issues.

  3. #3
    hey thanks i know i have 25 psi on idle on fuel but haven't check when problem is happening so do you know if the tps on the genesis is the same as the msx so i could swap or do you suggest new
    thanks

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    You can certainly switch them and try.

    1202768
    2004 PWCGENESIS ITHROTTLE BODY - W045098CA/IA
    2004 PWCVIRAGE ITHROTTLE BODY - W045101CA/W045101IA
    2004 PWCMSX 140THROTTLE BODY - W045303CA/IA
    2003 PWCGENESIS ITHROTTLE BODY - W035098CA/W035098IA
    2003 PWCVIRAGE ITHROTTLE BODY - W035101CA/W035101IA
    2003 PWCMSX 140THROTTLE BODY - W035303CA/CB/IA/IB

  5. #5
    yeah i see the sensor and i will try a different one so it there any type of fuel filter or anything like that in the tank the skis did sit for a while
    thanks

  6. #6
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Of the fuel system could be plugged along the way but you really can't take it apart and clean it.
    Maybe check with a local boat shop who works on the Ficht fuel injection systems and ask if they can clean the injectors for you.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 03 msx 140...dies at idle..plz help!
    By durkinz in forum MSX/Matrix
    Replies: 49
    Last Post: 06-10-2009, 05:16 PM
  2. '03 msx 140...deal? or no deal?
    By fastexas in forum MSX/Matrix
    Replies: 8
    Last Post: 11-14-2007, 02:45 PM
  3. reverse rpm limit 03 msx 140
    By boosis in forum MSX/Matrix
    Replies: 1
    Last Post: 10-14-2007, 05:09 PM
  4. 03 msx 140 impeller replacement
    By theedawgpound in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 08-09-2007, 10:53 PM
  5. Thoughts/potential problems on '03 MSX-140 D.I.
    By Nefarious in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-27-2007, 09:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •