Results 1 to 7 of 7

Thread: S/C clamp

  1. #1
    not fast enuf rwells173's Avatar
    Join Date
    Jun 2007
    Location
    Scullville, N.J
    Posts
    348

    S/C clamp

    what r u guys using after taking off the factory clamp on your s/c? a regular hose clamp or is there something better? thanks


  2. #2
    Looking for a job gtxsc03's Avatar
    Join Date
    Dec 2005
    Location
    St. Charles, MO
    Posts
    1,426
    I use heavy-duty stainless steel worm-gear clamps, other guys use t-bolts similar to these

  3. #3
    not fast enuf rwells173's Avatar
    Join Date
    Jun 2007
    Location
    Scullville, N.J
    Posts
    348
    where can i get them?

  4. #4
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852

    Thumbs up

    regular clamps work great and don't cost an arm and a leg

  5. #5
    Looking for a job gtxsc03's Avatar
    Join Date
    Dec 2005
    Location
    St. Charles, MO
    Posts
    1,426
    The standard clamps came from the parts store, I haven't had any probs with mine. The t-bolts you can get online or look for local speed shop that specializes in turbo installs . First one that comes to mind is
    www.siliconehoses.com or www.turbohoses.com

  6. #6
    Senior Member watermedic's Avatar
    Join Date
    Apr 2005
    Location
    West Virginia
    Posts
    383
    Any auto parts store should be able to fix you up. Go with stainless clamps.

  7. #7
    not fast enuf rwells173's Avatar
    Join Date
    Jun 2007
    Location
    Scullville, N.J
    Posts
    348
    thanks guys

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ride Plate Wire hose clamps...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 09-24-2008, 01:57 PM
  2. Rail Clamps
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-02-2006, 10:39 AM
  3. Hose Clamps
    By Tube Master in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-03-2006, 09:08 AM
  4. T-Bolt Clamp
    By Pale Rider in forum 4-Tec Performance
    Replies: 13
    Last Post: 03-05-2006, 02:53 PM
  5. Are these the hoses i am to put the clamps on
    By Jrsrxp in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-24-2005, 07:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •