Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Jul 2007
    Location
    Norway
    Posts
    11

    150 Speedster, 215 HP - Lost RPM, speed, and accelleration after 10 hours

    Dear users,

    I have a problem with my Speedster 150 - 215 HP - 2007 MOD.

    RPM Before: (MAX: Im not sure, but over 8000 RPM at leest.)
    RPM NOW: (MAX: 6500, and the engine has not the groove sound anymore)

    All of a sudden my speed went down from 63 mph (on a good day) to now max 45 mph if i am lucky.

    The acceleleration also seems slow up to theese 45 mph.

    I have:

    1. inspected to jetinntake.
    2. Changed the Oil (since i have run 10 hours according to the manual).
    When i checked the OIL, and found no pieces of ceramic.
    3. Checked that all cables are connected (according to the manual).
    4. Checked the impeller (looking in from the jetinntake) and it seems OK!

    I have no errormessage in the Display.

    My boat is no longer fun to ride.

    I hope you have some tips for what I should check.

    I cant think the washer is broken already? And if so, how could i EASY check for error there?

    Please help me!!


  2. #2
    braveit1's Avatar
    Join Date
    May 2007
    Location
    Jacksonville, FL
    Posts
    44
    The washer could be broken already. Don't discount it.
    If not the washer, did you check the wear ring? If you sucked up sand or a rope it can put a gash in the wear ring and cause you to lose speed.

    -either way, get the washer changed ASAP. There could be metal peices entering the engine if the washer did give way.

  3. #3

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by espenursin View Post
    Dear users,

    I have a problem with my Speedster 150 - 215 HP - 2007 MOD.

    RPM Before: (MAX: Im not sure, but over 8000 RPM at leest.)
    RPM NOW: (MAX: 6500, and the engine has not the groove sound anymore)

    All of a sudden my speed went down from 63 mph (on a good day) to now max 45 mph if i am lucky.

    The acceleleration also seems slow up to theese 45 mph.

    I have:

    1. inspected to jetinntake.
    2. Changed the Oil (since i have run 10 hours according to the manual).
    When i checked the OIL, and found no pieces of ceramic.
    3. Checked that all cables are connected (according to the manual).
    4. Checked the impeller (looking in from the jetinntake) and it seems OK!

    I have no errormessage in the Display.

    My boat is no longer fun to ride.

    I hope you have some tips for what I should check.

    I cant think the washer is broken already? And if so, how could i EASY check for error there?

    Please help me!!
    i'm sorry but it does sound like the ceramic washers have gone, the quickest way to check this, is to remove the big pipe which attaches to the supercharger, and put your finger in, if you can spin the turbine wheel with your finger then your washers are gone, ps the big round stainless steel clip which holds the pipe on, you'll have to distroy, and replace with the type you can tighten with a screwdriver

  4. #4

    Join Date
    Jul 2007
    Location
    Norway
    Posts
    11
    http://www.rotax.com/NR/rdonlyres/00...Thumbnails.jpg

    Could you please draw where the big pipe which attaches to the supercharger?

  5. #5

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by espenursin View Post
    http://www.rotax.com/NR/rdonlyres/00...Thumbnails.jpg

    Could you please draw where the big pipe which attaches to the supercharger?
    that engine is the wrong way round the supercharger is at the very back

  6. #6

    Join Date
    Jul 2007
    Location
    Norway
    Posts
    11
    Thank you so much for quick reply and answers. I will check it out.

    What to do if it is broken? Is my engine doomed? Only after 10 hours *crying*

    It is no sea-doo dealers here in Norway...

  7. #7

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by espenursin View Post
    Thank you so much for quick reply and answers. I will check it out.

    What to do if it is broken? Is my engine doomed? Only after 10 hours *crying*

    It is no sea-doo dealers here in Norway...
    if you want to keep it, it will require a full engine removal and new oil pumps, if not just put new washers on and trade it

  8. #8

    Join Date
    Apr 2007
    Location
    spring
    Posts
    166
    yep it is the washers, same thing that happened to mine, about the same time frame to. You will need to at minimum pull that front oil pump and clean it out and replace it, and ideally the pto one as well, both can be done with the motor in the boat since there is alot more room to work with.

    Find someone to do the work if you cant but it has to be done soon, dont ride it again. Also get the metal washers.

  9. #9
    sarasotabrit's Avatar
    Join Date
    Apr 2007
    Location
    Sarasota Florida
    Posts
    40
    Geeeez another one bites the dust

    I've had my washers changed out by Jerry ( great fast service btw ). I know people keep saying it but pls make sure you get metal washers on your superchargers changed before it's too late.

    Good luck dude.

  10. #10

    Join Date
    May 2007
    Location
    NWFL
    Posts
    42
    You would think with the number of problems they are having someone would be on their tail about this issue.

    J

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Friends seadoo speedster 215 hp only hitting 7600 rpm
    By JeffStalone in forum 4-Tec Performance
    Replies: 14
    Last Post: 04-22-2016, 12:11 PM
  2. RXP 215 -06 Losing RPM/speed/power
    By Saki in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-24-2014, 03:09 AM
  3. Speedster 155 hp 2008 top speed
    By Yam in forum Sea Doo Sport Boats
    Replies: 18
    Last Post: 11-26-2013, 09:09 PM
  4. 2007 Sea Doo 150 Speedster 215 SC question
    By Tim Barrett in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 08-11-2013, 09:30 PM
  5. F.S. 2007 150 Speedster 215 HP Red
    By NCRXP in forum Sea Doo Sport Boats
    Replies: 12
    Last Post: 10-14-2007, 09:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •